Oldsmobile Cutlass Supreme Questions

Unanswered Oldsmobile Cutlass Supreme Questions

Ask a Question
View:RecentAnsweredUnanswered
had it towed home. Now it will start right up however runs really rough and oil light still on. Oil show's full. What could it be? Was running fine before.
I'm trying to replace the pcv hoses and make sure I connect everything also valve on fuel rail is leaking so will a o ring in cap help? Thanks so much
i went to go to store and car was sounding better and wasn't smoking anymore than it lost all power the engine just stalled I went to pull over than it died now won't start all the time cranks over just doesn't start ...
I need to replace the ESC module but do not know where it is.
the door wont open from the inside or outside. i just replaced the door handle and pannel because the old one broke and then when i tested the locks it wouldnt unlock from the inside or outside. how do i get the door ...
Turn headlights on, defrost turns off, dash lights off, while headlights on, apply brakes and headlights blink?
When I go to start my car, it doesnt crank or start, makes not one sound at all. Does that mean that my starter went bad?
It covers the door chimes,door locks and power antane.Serveal people are saying it has a short.Any way to check.Thanks
changed head gaskets and intake gaskets set the timeing and now i was told to i have to take valve covers off and quarter turn the rockers how do i do this step by step 81 cutlass supreme v6 3.8 can hear the lifters t...
Noticed like a metal grinding noise in the front of the car. First noticed when it was idling, stopped when I started driving. Then noticed it every time I started the car as well and would cease seconds after and dri...
I want to gain access to the cradle bolt nut without taking it all apart. I have the new nut and bolt, but I don't want the big expense of taking it to a shop. I want to do it myself.
I have a 97 Cutlass Supreme. A month ago it was fine now suddenly about a week ago it wont start. Here is a list of some issues I noticed and hope someone will read this with some helpful information. Car wont start ...
I noticed that the 2 fans directly behind the radiator are not spinning, when I'm in park and allowing the car to get hot? could that be the problem and how to fix?
replaced a/c compressor, condenser etc and now wont start. Double checked all wires etc. all hooked up found I had 3 volts to fuel pump but no pressure at fuel rail so I replaced the fuel pump Still wont start Do ...
Has a poof sound and has a miss when giving gas while in park.replaced starter poof noise is coming from the motor car has a chug in it while giving it gas in park. Drives fine.
The car drives fine ,but in park it chugs or has like a miss . This only happened after I replaced the starter. When I crank the car it makes a poof sound near the motor like a leak or something.help.
wires in trunk coming off pump,changed ecm 2x. car wont start w new ecm, starts w old ecm reinstalled. can stop pump by disconneccoting pump wire in eng compartment to battery
Dave Bush at Precision Auto Repair in Garwood NJ damaged my 1970 Cutlass Convertible- He over filled transmission, left bolts out and let water damage occur - he neglected my car and worked on his friend Joe at Westfi...
Catches 1st gear 3rf gear only when letting car shift itself.
I have no problems getting it to start or restart at all runs alittle rough once in awhile
Changed solenoid and did not get better. Just click a few times and it used to start but just click now
I just got an oil change and a tune up...the battery seems ok but idk
Oil is leaking into my overflow, been cleaned out and a sealant put in, it helped for awhile. Has never over heated but heats up if i have to idle too long. Then cools down when moving. Dont want to be ripped off. How...
car stalled out in water, started few hours later and ran ok but wouldn't rev higher than 3000rpms. After I drove a friend from Peterborough to buckhorn then drove back to Peterborough the car revved at 2200rpms on i...
the car will turn over but not start up i replaced the module now i am trying to repair the crank sensor