Nissan Xterra Questions

Answered Nissan Xterra Questions

Ask a Question
View:RecentAnsweredUnanswered
My service engine light was on for the catalytic converter 420 Bank 1 and emissions. I had the cats replaced and the 420 code came back on in <50 miles. The mechanic check tested the catalytic converters on both banks...
There is no slip while changing gears, but while in drive at a stop and sometimes while mobile, I will hear this whining noise. When in park and sometimes at a complete stop it goes away. Someone recommended transmiss...
with the a/c off car runs fine all the time
My 2004 xterra looses power have to floor it to get power back then adventually loose all power and stall. Won't restart unless sits for 10 or min. But then stalls again. HELP please!
I just bought this vehicle Wednesday from a used dealer. Drove it all the way from the dealer to where I live, different counties. Noticed some smoke but figured from the heat being on, was told that isn't the case. U...
Drove over 2000 miles when I first got it and worked fine. Let it sit up about a month through December. Started driving again and heat only worked when at high speed or overfilled reservoir. Then started overheating ...
change dist knock senor fuel pressure is good idle control valve coolant temp sensor and still turns off after 10 minutes on
I have a 2000 exterra 3.3 l engine with 74000 miles cold start the engine has a noise like a lifter not getting oil but gets quiet when engine is up to operating temp does not seem to b getting worse or better sugg...
The battery seemed sluggish to start the vehicle in cold weather but it would start. Today,which is much warmer, it started up when I drove home from work. Was about to leave an hour later but vehicle would not start....
I had brakes put on in december, they were still squealing took my truck back they claim I needed the rotors resurfaced, had that done in december as well, my brakes still sond terrile. Is that normal to have them res...
when motor warms up it will stall and choke down
I replaced the bulbs but they still do not work. I know where the backup light switch is, but I can not find the backup light fuse
Makes a strange whirring noise now. Just before it died the wipers started going really slow. Headlights work, battery terminals are cleaned and it's a new battery
Crank sensor. Still have extended crank time and p0340 code is back. Also have the slip light and vdc lights on other then this truck runs great
just stopped working, replaced the resister and heater blower and still the fan won't work could it be the heater switch itself
My xterra has started being very particular about when it will start. It starts fine when it is cold, but once the engine is warm, if I turn it off, it will not start again until it cools down. At first, I thought it ...
What could it be if the fuses are all fine? I checked all of them since none specified dash/tail lights.
Will go off after a few seconds or won't do it at all if air conditioner is on. But will start again when I turn air conditioner off
When started it immediately goes to high. Oil reading good, new filter and oil.
last week my heater was making my car unbearably hot, even when it was off. now this week all I can get is cold air. I have checked all the fuses, none appear blown and I don't see one specifically for heater