514
questions

A few days ago my I was driving down the street & my Xterra began to stall in speed. I could press the accelerator to the floor almost & wouldn't go past 20mph.Pulled over & it wouldn't reverse or go str8. Had it towed & it drove just fine on to the flatbed. Took it to mechanic next day & had a transmission flush done. It looked & smelled like burnt oil. Chocolate milky like. It ran fine during first test drive then took another drive & the stall was still there. Now I'm told it is the transmission pulley??? Is this the best way to go or just simply replacing the transmission. I just DON'T want to be taken advantage of. I am a single, hard working Young female who tends to find men on these lots & shops who have told me anything to benefit them & just need truth & unattached "looks" advise. They always trying to talk to me on a more personal level until I show NO interest in them but business & then, I seem to get done over with NOT worth advise & purchases. Just bought the truck end of Nov. Only has 123K miles but I travel ALOT with work in this vehicle so they are really ALL Hwy miles. I want to do whats SMART!!! Please help!!!

The the guage shows almost full and the check engine light will go on.

Why does water pour down in passenger,front floor everytime I use my ac? How can I fix problem?

My Xterra has 177,000 miles on it and the seals in the rear axle are leaking. The dealership said the whole axle has to be replaced for around $2500. In addition it didn't pass inspection due to emissions, possibly a bad catalytic converter. I just replaced both rear leaf springs with OME Dakar springs since the drivers side leaf spring snapped, this was the third time a leaf spring broke on my Xterra. I don't even go off-roading or tow a trailer or carry heavy loads. At least the new springs won't break again. Is it worth getting the needed repairs done or is am I just throwing money out the window?

2013.Made payment's for over 3 year's on time and never a missed payment.I have about a year left and the transmission stopped working due to cross-contamination.I googled this and found that this was a known problem with the 2008 Xterra and that there is a class action law suit because of it.The finance company is still owed over $6000,by me,and it will cost me $4,200 to repair the Xterra.I don't have that kind of money and i am on a fixed income.They will repo and my credit will be no good.Is there any thing i can do to get my Xterra fixed that i can pay over time?I tried a personal loan but i have too big of a debt load.Now i have another car and it is going out on me.What in the world can i do?

I keep getting a check code P1441 It is a slow evap leak. I change gas cap. I put new fuel filter in. Change the air filter. New fuel filer hose in. Brand new o2 senors. New exhaust.
I even use shell v power gas only. New spark plugs. what else could it be?

When I start the Xterra, I pull out and once I hit about 23mph,it would start whining horribly on the front left, progressively getting worse until about 30 then would stay the same but then, when you slowly decelerate it would click and feel like something caught and not make the noise again. I am very worried now because it is starting at a lower mph like 12 yet still stops when I slow down. HELP!

When i switch on the ignition switch the malfunction indicator light not come ON before starting the engine







When I accelerate when in Park, the shaking stops. But pulling in and out of drive way it shakes and engine bogs.

up the brakes the brake pedal goes back down. what is the problem?

I have changed the battery cables, fuel filter, crankshaft sensor, injector cleaner and I am only running premium fuel. I dont know what to do next and I am curious what advice anyone has on this common problem with the Xterra.

I have changed the battery cables, fuel filter, crankshaft sensor, injector cleaner and I am only running premium fuel. I dont know what to do next and I am curious what advice anyone has on this common problem with the Xterra.

I'm looking to buy a 2001 Nissan Xterra for my son's first car.

It's a 2.4L 5 Speed Manual, I believe 2WD with 197,000 miles on it. The car appears to have been maintained very well however, I do not have any receipts on the truck.

I do not know much about the Xterra, so I'm hoping for advice as to whether we should make the purchase and/or if there are any parts of this vehicle in particular we should take a look at.

Thank you in advance!

brother said need to replace catalytic converter

My service engine light was on for the catalytic converter 420 Bank 1 and emissions. I had the cats replaced and the 420 code came back on in <50 miles. The mechanic check tested the catalytic converters on both banks and everything is working correctly. Does anyone know what might be going on? I am unable to pass my smog check because of the service engine light still being on.

There is no slip while changing gears, but while in drive at a stop and sometimes while mobile, I will hear this whining noise. When in park and sometimes at a complete stop it goes away. Someone recommended transmission filter/fluid change. What is the average price to have this done so I don't get bamboozled. Thank you.

"Gently" used vehicle, no towing or off road use.

No leaks. No getting hot. Ac blows cold. now it has a rough idle And check engine light Is on. Wtf! Help? Lol it is aluminum block so it it warped? Or the head warped? I seen where the head gasket blew. Well close.....it was right below the head and right above the block spraying vapor from behind the exhaust manifold shroud. Really is a solid 2001 X 3.3 se 2wd. Girlfriends car and she's convinced it's junk. Haven't drove it yet since putting bars leaks permanent block sealer.143,xxx miles still paying on this car mart special.........


410 a month.....



(WELL IM NOT SHE IS LOL BUT IM TRUCKLESS TILL THEN)


HELP? HELP? HELP?

I bought my 2007 Xterra a year and a half ago from Nissan. It worked fine until I took it in February 2015 for inspection and drove away with my fuel guage all of a sudden reading empty and check engine light on. I had just filled my tank. I took it back to them they wanted to charge me $400 plus to fix it. I complained researched online and say the recall that included 2006, 2007 and 2008 Xterras. Nissan National declined my truck under the recall saying the vin was not part of the recall. What if anything can I do? Been just monitoring my mileage and filling up that way.

with the a/c off car runs fine all the time

It seems like Knock sensor in a Supercharged Xterra is located in different area than others models.

The vehicle has 45k miles under normal usage (not off road) and my mechanic is recommending a differential oil change.The Owner's Manual is silent on this service. Does this seem appropriate? Many thanks.