Mitsubishi Questions

Unanswered Mitsubishi Questions

Ask a Question
View:RecentAnsweredUnanswered
when checking tranny. no pressure on the fork of throwout bearing. replace flywheel,clutch,pressure plate,bearing, started to install but still no pressure on fork. looked at old parts still half of clutch plate sti...
I USE A HAIR DRYER TO DRY IT OUT WHILE STILL ON.STARTS FINE WHEN WARM,BUT BIT DANGEROUS HAVING HAIR DRYER IN RAIN FOR MISSES HELP HELP IN NEW ZEALAND AND NO BUGGER CAN SORT THANKS FOR ANY REPLIES
Hello Thank you for your time Car using oil, 1/2 qt every few hundred miles, only 60k on motor, no visible smoke or leaks some black on tail pipe ends Any guidance appreciated
The car was not accelerating and misfiring then one day it wouldn't start I replaced the camshaft sensor which did nothing also replaced the fuel pump and timing belt I was wondering if any has any advice at all would...
I changed upstream o2 censor,camshft censor,pcv valve.Im changing the alternator belts soon because it also squeels sometimes too.
was going down the road and the car just would not go no more
All power windows and locks only work from time to time. Not able to use keyless entry to lock or unlock doors. While driver side door is open the noise of the locks clicking can be heard but doors are NOT locking a...
Hello wondering if you could please give some advice. Code is reading a random misfire, two of the 3 coil packs are fine but the 3rd gets no spark at all. I replaced the coil pack and still nothing. My friend was goin...
sometimes when I first start the car in the morning it works but not properly. the tach does move but only up to 2000 rpm then stops working. other times it doesn't work at all. plus my speed isn't accurate either? wh...
Replaced distributor thought it was cam or crank sensor replaced ecu when it doesn't start it is not getting a spark if you keep clicking the ignition eventually it usually will start thanks for any advise don't know ...
its runs at normal temperature. it isn't over heating, but the light is annoying to look at! lol where is the sensor located at? also there is a light gauge under the radiator symbol that is on too. what is that?
Driving up hill , Car cuts off and will not restart. Total loss of power . I thought maybe a timing belt , but no clunking sounds as if valves had collapsed or rods bent etc.Turns over good , but not starting .I also ...
It will not start. When you turn the key, you hear cranking but it just wont start up anymore cheek for a code but im not getting any bad code has a new alternator new battery i cheek the star motor is good i was thin...
Replaced that 02, cleared the code and it still comes back. Tried confirming by swapping it with the Bank 1 sensor 1. Still keeps throwing at least that code. Drove it with my scantool and it seems fine in the baud ra...