Mitsubishi Galant Questions

Unanswered Mitsubishi Galant Questions

Ask a Question
View:RecentAnsweredUnanswered
It jerks when I'm driving it and when I step on the gas, it revs up it the speed doesn't change. And at a stop light or a turn or backing up, it sometimes dies. It doesn't do it all of the time but it's getting worse....
Can't reverse,nor accelerate, can't get power on a hill,its stops or move very slow,or stalls,when idle its makes noise and vibrates like wanting to stop,please help I have tried all I can guess,your response would be...
the car runs fine till it loses power, then the steering wheel stocks up. brake loses and the engine sounds choking till it dies. what could be the problem?
My car was shaking and it cut off on me and would not start so I got is tuned up and it runs but every time the car brakes it shakes even when u turn it on it shakes what could it be?
I USE A HAIR DRYER TO DRY IT OUT WHILE STILL ON.STARTS FINE WHEN WARM,BUT BIT DANGEROUS HAVING HAIR DRYER IN RAIN FOR MISSES HELP HELP IN NEW ZEALAND AND NO BUGGER CAN SORT THANKS FOR ANY REPLIES
The car was not accelerating and misfiring then one day it wouldn't start I replaced the camshaft sensor which did nothing also replaced the fuel pump and timing belt I was wondering if any has any advice at all would...
I changed upstream o2 censor,camshft censor,pcv valve.Im changing the alternator belts soon because it also squeels sometimes too.
For some reason, most times that I accelerate and when my foot comes off of the accelerator, i can hear a slight ringing sound similar to the sound of an empty metal bowl. What could be causing this and how much would...
I've replaced the belt & Alternator and after a day or two it's rain it will start up squalling its will get worse like if I get ready to stop it will squill at night when I start the car up.
i have a 99 galant 2.4l 4 cyl. i turned it on this morning and it started to idle high. the service engine light came on and i took it to autozone and advanced auto to scan but they couldnt retrieve any codes nothing ...
I asked a lot of questions and looked on line but I could not find any thing. The only other thing is the heater hoses are hot going in is hot the one coming out is cold
car startedt to buck but came back on go home went to start the car an hour later and nothing works
My heater won't work
Trans installed 3 weeks ago. Working fine then now wont stay started in drive gear
driving my 2012 Mitsubishi Galant & all of a sudden the oil signal &car cut off
This happened at the same time. According to my research these two accessories are on two different fuses. Is it possible they both went out at the same time?