Close
553
questions

Car sat for a month once I put a new battery every light on the car came on and won't go off. Tried to crank it but only tried to turn over and spits out windshield wiper fluid.

My car ran great with no problems what so ever and the next day it wouldn't start. It would turn over but wouldn't start. I checked to see if it was getting spark to the plugs and it was not. I checked fuses and everything else and still can't find a solution.
The option wasn't available but it is a 3.0L v6

The idle is real low in gear ?

2009 mitsubishi eclipse. Was shampooing carpet in car when this happened

Need a visual

I've replaced the radiator thermostat and actuator and I still can't get heat to the vehicle

MOTOR MOUNT AND POWER STEERING BELT

POWER STEERING BELT AND MOTIR NOUNT BROKE IN HALF

Then when I let out on the fuel and RPMs come back down it seems to shift fine until tries to catch the next gear then it vibrates and my RPMs jump all over the place I'm not sure what's wrong with it

Need to know if it has a drain plug for transmission fluid

I want to know about 2012 air bag lighto
on passenger side on .after replacing new battery

Gas pedal will not move

Car shut off and will not start back up

How much is a wire harness for a 2008 Mitchubishi Eclipse Spyder with a 2.4 in it And can I take the motor from it and drop in my 2004 Lancer ES

The inside of my Spyder burnt completely up! Only motor and the body is left that is good. But everything on inside is completely burnt. Where is the computer located on this vehicle

Car won't start and won't give any diagnostic report when connected to the machine

I want to install an electrical oil pressure gauge in addition to the "idiot light" set up from the manufacturer. I want both to be operational so will need to add a part (a block to connect to the engine that will contain both sensors. I am dealing with Summit Gauges and they will find me the parts required if I can give them the data regarding the OEM oil pressure sensor threads into the block. V6 engine 2001 Spyder.

I'm leaking oil bad, had a new water pump put on, now having a bad oil leak

It only works on 4 then the fuse blows

when going up steep grade car looses power. you have to let all way off gas until almost at a standstill and then apply gas. sometimes it will go ,m most of the time it just barsly moves.

we aren't wanting to have to take anything else off of the car. is there a way to put this coil back in the engine without having to take things off of the motor to accomplish this. is there a tool?/ can something be made from home to do this job./

Wont start

Is this something I should be concerned with? I'm in the process of buying this car

It's a 2003. I also have a 99 eclipse, can I use parts from the 99 eclipse to repair my 2003? My back right shock just broke and problems with the clutch

Had transmission rebuilt a year ago.

the shop has put 4 computers in the car he says it feeds to the computer from the coil but wont feed into the system. could this be a security lock out and if so how do we reset it. the car has 2 keys 1 for doors and 1 for ignition. mitsubishi said that the comper has to be programed to the vin # my car went into the shop because transmission had to be fixed it was running when it went in to be fixed

2003 Eclipse GTS 3.0 6cylinder

The tinting film is old and makes it hard to see out of the window.

It has needed one for over a year.

I notice the problem when shifting from park to reverse.