Mercury Mountaineer Questions

Unanswered Mercury Mountaineer Questions

Ask a Question
View:RecentAnsweredUnanswered
IVE REPLACE THE MOTOR REGULATOR, IVE TESTED THAT SWITCH WITH THE BACK SEAT AND IT WORKS, BUT FRONT WONT, I MISPLACED THE WIRING HARNESS THAT CONNECT TO MOTOR BUT JUST TRYING TO SEE IF IT WILL WORK BY USING PUS IN PINS...
So I have replaced a few other solenoids on this SUV and had no problems however solenoid 3 has now burnt out 4 times, each time getting shorter from the last time. Just replacing the solenoid and spark plug is not en...
supect G.E.M.malfunction heated seat-power windows-driver side power lock-interior light dim switch-high beam and fog lamps- All systematicly went down after working eraticly one after another...All fuses and relays g...
When we first got the car in 2014, the car started right up. I drove it for 100 mi. Shut it down at a rest area for about 20 min. Went to dive off and it would not start until the next day. Once started, drove it hom...
why can't the power side view mirrors, be adjusted while the car is running? They only can be adjusted when the engine is off, and the key is on accessories. That does not make sense.
when the car is running< I can not adjust the direction of the mirror.
My husband hit a parked car while he was pulling out of parking lot causing the front right lower control arm to bend or break. We drove it for an emergency vehicle only and very slowly like 3 times. It pulled to the ...
bolt on bottom passenger side is hidden. Does something else need to be removed first?
My engine light came on . The mechanic said it'll cost $350 because he'll have to take the engine apart to install the part. Is that true?
continuous grinding and knocking sound thought it could be an alternator but was told it could be timing chains and oil pump loses pressure then a few minutes later builds back up vehicle has 183,000 miles on it
I had to unplug from washer motor to get it off plunged back in came back on what would cause this.
What I thought was an exhaust leak maybe valves needing adjustment.
However, it works in the evening when the lights come on (they are on auto).Most of the time they only work half of the time at night. What could this be? Please help Thank you
I have had the battery tested and it's good. I go to start my truck and it is like the battery is almost dead then it starts and all the gages max out for about 3 to 6 seconds. Then I have to drive with 2 feet one on ...
It will not give me a code. Has 168,000 miles.
ok so when i take off the motor pumps power and at idle reving in nuteral motor sounds great. But when i take off it powers off the line just fine but about 15-20mph it feels like i lose a cylinder or something. i hav...