Close
429
questions

my top will not go up or down I had the 2 front cyl. relpaced last year,but I would like to get the hard top off. is there a place I can get a drawing where all the cylinders are? thanks , by the way we only drive the car about 1500 mies a year,it is a Silver Arrow,

Full tune up complete. New crank sensor, fan clutch, mass air sensor. Runs great except at idle with air conditioning on. Any help???

Thanks

Other problems/solutions to get the passenger window fixed? Module Mercedes Part # 129 820 24 26 needs diagnosing if it is not a relay? Best least expensive fix for this part? Going to unhook battery to reset module/sensor codes...have to also enter radio code...will this effect window operation? Can this be done without effecting other settings for engine performance? Are there additional window switches other than the center console ones? Where? Is there a window lock out or child safety setting switch? Where?

How do i get rid of the bad odor

where is the Map sensor located

DOES THIS MEAN I NEED A NEW BATTERY INSTALLED. IS THERE ONE IN THE TRUNK?. PLEASE REPLY

this leaks when top is raise.

is it under the dash /

is it on the inside

I believe the leak is at a cylinder on the left side

I have an worthless extended warranty but they say it only covers lubricated parts.I am scared to drive because it may not get out of park. Anyone experience thesame problem

is the power steering pump a two pump one part for abc other for power steering

i already removed the shift lever wood cover.still remaining is the radio wood cover and the whole console assy. as well. is there any hidden bolts?help me pls. thank U.

The car will drow when it set for 30 min or more but when the engine is started and the car put in drive.

my question was well over 10 characters

hello there i don't know what to say but i have a serious problem and no one can give me the answer ...my problem is that sometime my car start to shake(vibrate) smoothly when it is not moving like when you have problem in the sparking but when i restart it this shaking gone .

hello there i don't know what to say but i have a serious problem and no one can give me the answer ...my problem is that sometime my car start to shake(vibrate) smoothly when it is not moving like when you have problem in the sparking but when i restart it this shaking gone .

mercedes benz 1997 sl500 ...how i change angin timeing

This problem happens eveytime. No problem during acceleration.

On my CarMd tool in said it may be a camshaft timing sensor.

The engine turns over fine but does not start. It has spark, but does not get fuel.

motor mount and trans.mount fits right . knocking noise coming from underneath passenger side. especially if turning right. no more noise after cruise 25 mph.

Passanger side power window up and dead. No motor sound no response from switch and no listing in main fuse box for power window fuse. Is there another location for this fuse? If there is no fuse for this, what should I check next?

when i replaced the k less batterys the both doors didnt open, i used the secondary to open the doors. car startrd up, dont forget it s about 25/30 degrees out.then the radio goes on then shuts dwn, sometimes it works, the fan started out slow for the heat then about 5 min or so everything was fine.i had both batterys checked their fine. my cig/lighter does work. guys what do you think ?

try it the second time still didnt open, took out the secong dairy key & started the car. wheather degrees about 30 f night time, radio goes on & off & the inside head lamp lights didnt work. after car has warmed up everything is fine. still the radio has issues, sometimes it will work other times no.could it be fuses, relay or what any answers guys thks rich, rjs134@att.net

It's well established that the shifting assembly was faulty on these cars.

need a new ket to start the car

Took the car to have an oil change and the mechanic came in and said the car wouldn't shift out of Park. It was stuck. Some think it might be the parking cylindroid and others have guessed it will be the shifting assembly.

But when I start and put in gear, it levels itself. I head someone indicating that it is due to dirty hydraulic fluid in ABC system and suggesting to extract it from the top and replace it, but I do not think you can suck out all the oil!

The altenator warning light goes on and off. I replaced the altenator two times,and still have the same problem.
Both altenators checked out to be good.
Do you think the wire harness would cause this?

Do I need any special tools