353
questions

I can't get my navigation to come on when I select navi from the panel. Everything works but I can't see nothing on the screen.

how much to repair

I found the panel near passenger foot but which number is for cd changer

everytime i start my car up the entrance light comes on. And when i turn it off the driver side drops down.

my Mercedes has been setting in the garage for a few months and the battery is dead how do I jump it off?

Where is the access to the left turn signal lamp and
do I need a special tool to replace lamp???

Thank your for reading my concern, and question.
This is what I know so far:
I purchased this card about (3) months ago and the car would lose air pressure in the front if i did not drive the car every day. I would let it sit for (3-4) days, and the car would be low in the front. Im unsure if this is normal, but, when I would start the card, and would rise with no problem. Even if i did not push the button on... but turn car on, the front would rise.
HOWEVER, last week I turn off the car, and a loud noise was coming from the air suspension pump. Even when the car is off the pump would shake really bad, and make loud noise.
TODAY, it makes no noise, does not shake, and the card wont rise. The car is not low in the back. Only in the front. And the right/passenger side is leaning more to the ground than the driver side. But, the driver side is low too.
i never heard air leaking from anything.
Could this be the air pump, or relay, or failed air shock?

I just replaced the transmission control unit.

are there 3 fuse boxes?. two under the hood-inside the engine compartment, where is the third one if the car has three fuse boxes.

trunk sounds like it is going to open, but will not open remotely from inside the car or with the remote. Trunk only opens with the mechanical key. Also have to push or force down to close the trunk; trunk lid leaves or hangs about 3-4inches gap.

stereo and gps works, but no sound out of speakers. Checked the fuses inside the two fuse boxes under the hood and they are all ok.

What is this? I know the seat belt maybe part of the problem I need more info.

more fuel consumption.

gomy good s430

i had it towed to the deaier and they said bad pump brought it home got new pump and relay still nothing.fuses under hood are good any ideas

Hapens when driving and my foot isnot on the brake pedal.

IT SMELLS LOUD OF GAS OUTSIDE CAR AND PUDDLE UNDER IT A LITTLy

Is the TCU located under the car in transmission area?

Battery was flatten by lights left on

please help i need to get my car inspected

sometimes my speedometer works and sometimes it doesn't,could the problem be a fuse? if so where is it located? thanks

my speedometer goes up to 30 mph then drops to 0. as of now it has stopped working , but it records the mileage.

Changed the battery in the key but still wont open anything. Any help would be greatly appreciated

Speedometer not lighting up

I have the bulb but am unsure how to install

I had to replace the airmatic suspensions on both front RT/Lt, IThe blower motor was replaced in 2005, now it is out again. I have had to have the computer repalced, there is a link under the front passager's dash and the repairman don't know where it is coming from.

The lights appear to point outward on both sides.

The oil pressure is low at idle but increases when moving at higher speeds.

Problem just occured. Worked fine during a short 20-mile drive. After sitting for three hours, blew hot air. No sign of coolant leak. Sat overnight, blew hot air in morning. Have no technical stuff.

checked the battery - good; checked all fuses and relays - good; used a second/spare key and reprogrammed the key - did not work; other components are working just will not crank nor start. What else should I check or know to diagnose the problem?