Mercedes-Benz 300TE Questions

All Mercedes-Benz 300TE Questions

Ask a Question
Odometer/trip counter has stopped, speedo works.
The horn also stopped working at the same time. I've had the elect harness and fuse box changed in the past, but elec problems seem to happen periodically.
It seems like it isn't going to start then when I put my foot down on the throttle it eventually fires. Mostly happens when it is warm.
When I jump pin 1 and 2 I ghet excellent flow fuel into a small container for good 30 seconds... then I install MAS relay (which has fuel pump relay inside) and only get trickle for 2 seconds...tried used spare....
it has a strong cranking ut still wont turn over is there a reset switch or a fuse for the fuel i hear the pump running but it wont turn over first time this has ever happened
Recently changed fuel pump, plugs, wires, distributor cap and checked coil resistance: .8 ohms primary 8,300 ohms secondary cold. Seems ok. Any suggestions where to go from here ??
sputter is random...started about 2 weeks ago i notice more obvious when go from stop to cruise speed...once cruise about 60/70 mph its better....replaced fuel pump located under chassis right side rear passenger area...
fan doe's not work on high speed or auto speed,only on low speed.
fan doe's not work on high speed or auto speed,only on low speed.
I know it's a wagon and is part of the "E" series, but what's the T for?
my car won't start in hot weather
It pumps fluid through the system---back into resivour, but when you adjust the valve lever up & down, nothing happens--- stays in the down position. Rides fine, Air accumulators are new, plenty of fluid. Can it be...
oil in the coolant. Do they make a teflon gasket for this mercedes? And does this year car always have gasket problems? Thank you
I know that I will need a special tool to get the radio out, so where do I get it or do retail stores have the tool when I take it to them to put a new radio in? What all do I need to remove to get the original radio...
car was fine it has not beenmoved for over 8 mos however always start to keep flow of lubrication thruout. now after 15 minutes or so it will over heat up to 210 deegres and lot of bubbling n reserve container hear no...
car will not start battery good turns over will not fire new spark plugs. put dry gas in.email is dhersh56@yahoo.com
fluctuating voltage levels,flickering bulbs,cruise c. auto shuts.
My husband worked on my car couple weeks back replacing the stabilizer arm and now my transmission is not changing right. What could he have done to it?
THE BATTERY LOSES CHARGE AFTER ABOUT 5 DAYS. THERE IS A SPARK WHEN ATTACHING THE NEG. CABLE. I REMOVED/REPLACED FUSES ONE BY ONE UNTIL NO SPARK AT NEG. CABLE. THE BATTERY NOW HOLDS CHARGE BUT TURN SIGNALS AND FLASHERS...
Just bought a 300TE and it is a great car but I have replaced the motor mounts, radio, antenna and headlight doors. Had to tow the vehicle 200 miles after a wheel bearing broke. Would it be a good idea to replace bo...
My car is actually a 1988, but I wasn't given that choice
Does my 1991 take R 134A and where does it go in at?
I have replaced the transmission with a new one. Replaced the O2 sensor, the cam sensor, the BDU, and had a full service on the car. All to no avail...The car is fine to drive around town, smooth responsive. On the ...
i want to know how can i fix the driver side seat,i checked all the fuses and that don't seem to be the problem.Is there something else?please help out my seat is as far back as it can go(stuck)thanks
Occurs mostly in warm weather and occassionally while running. Thermostat stays pretty much at midrange. Replaced idle control valve and ran good for a while then problem recurred after a month.