409
questions

when i restarted the car it acteds like it was going to cut off low rough idle lungin sort of like when car runs out of gas and you get it running.. new plugs,oil, coils,transmission flush, car was perfect for the first 10-15 miles drove since vandalized then all of a sudden it sounds like a sick john deer tractor with a flashing engine light..surges,idlesrough almost dies, continuously,, doesnt get better

I have an interesting problem that has me stumped. The car won't start with out a jump. The battery is new, the alternator tests good. The cables are not corroded. The fuses all seem to be good. I can usually start it once after it has sat for a while but if the engine is warm, it will not start. The engine does not overheat. There is no check engine light on. Any suggestions would be appreciated.

Mine is a weird one, turn key, car starts, then immediately dies, try again, but this time hit the radio power switch & everything is fine!!!!!!!!, also central locking does not work, other that that everything is good, car will run all day once started, like I said weird

So basically, I cleaned my throttle body about a month and a half ago, ever since then my car hasn't been running properly. I drive a manual, so the rpms have to be at a certain spot right? Well, they often drop and go up a lot and end up in my car stalling. People have said its the throttle positioning sensor, or the throttle body sensor, an since im not a mechanic, I have no idea. please help!

Mazda protege 1992 has no power steering been driving for a year had started to over heat shut off then wen turning back on I drove about a foot b4 I noticed staring wheel won't turn

I am a mechanic and not use to working on Mazda's. I recently have had problems starting the car. It cranks excessively before it starts. Once it starts it runs fine and I have great fuel pressure. I thought the fuel pump check valve in the pump was bad and losing the prime. But I noticed when I was removing the pump I turned on the ignition to check the pump out of the tank that it doesn't run for a few seconds to prime like today's fuel injected cars do, so I am wondering if it is the Fuel pump replay is malfunctioning. What is your ideas?
P.S. I went ahead and installed the new fuel and strainer pump since I had it out anyways.
Thanks

Mileage 130,000

replace rack and pinion system

have checked all fuses,and connections in the a/c system I worked on,checked bat. connections and all are good. checked for fuel and spark. I do have good fuel pressure but no spark

I put oil n all in it n put a brand new battery in

I dont get any gears. I take it the possibilities now are a powertrain control module... and ? Anyone anyone... buehler... buehler.
HELP ME SPOCK! Im desperate. Thanks

repair shop says I need two cylinders and a tune up and spark plugs and wires

Car starts when cooled down but not cold.after driven will not start till cool down..makes no noise when key is turned to start.

Car starts when cooled down but not cold.after driven will not start till cool down..makes no noise when key is turned to start.

I have error code 1569 on and failed emissions test again today. I have one more attempt to pass. 1569 is an error with vtcs solenoid. I have no idea what this is and how to fix it. Any suggestions and/or estimates I'm looking at to get this fixed so I can pass emissions? I'm on a very tight deadline! Please help!

I need an answer asap for emission testing.

was told by my mechanic that I needed one becos car is/was not changing into third gear.........hmmmmmm

not blowing cold air ,will not work on level four

do i have to seperate the motor and trans

I purchased this car but the original engine had already been changed to VVT engine and rewired, Since then, the temperature gauge has climbed when going uphill but further observations showed the vehicle is actually not overheating and there is no restriction in the airflow system. OBDII code P0443 is present and we have replaced the temperature gauge sensor at least 3 times and the airflow sensor as well.I'm lost now...

It's not even coming on when car starts. We have changed all the bulbs as well and no OBDII codes are showing up?

how do I change out the clutch on this car like what are the stepsi need to know the easiest steps to replacing the clutch

I have tried replacing the bulbs (front and back) multiple times. I have checked the fuse and that seems to be functional. Is it just a fault in the wiring? And if so, how much would it cost to get that fixed? When I turn my headlights on, the right turn signal will come on, but it won't blink, and the left turn signal will blink once and then stop. But when the headlights are off, the left turn signal works perfectly well while the right one shows no signs of life.

had trouble brakes click when stoping car, it does not click when turning

after car sits for a few hours it takes a long time to start,i smell fuel,and it sounds like it wants to start, but wont,only after 15minutes or so of cranking the car finaly starts, after that it starts fine evrytime...as long as it dont sit for 2 hours..please help, any info, or suggestions are more than appreciated

It happens once out of every 10 starts anytime during the day.