Close

Mazda Protege Questions

Get answers to questions about your Mazda Protege at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
418
questions

I have replaced radiator,thermostat,head gasket,and thermostat housing flushed system refiled with straight antifreeze,and wired both fans direct with toggle switch and still am overheating.

Still same and gerting worse whats next the injecter?

I feel a wobble or shimmy in the front left wheel, and it the tire might be having trouble rolling.

It feels like its sputtering when its running.

i ran a scan on the car and a code came up p1345 i was told that was the cam sensor so i replaced it and replaced the plugs and wires too. any thoughs.

It moves as much as 15 degrees advanced. The engine is idling rough. The check engine light is not on. Why is the strobe light so erratic?

I have noticed it while driving straight, but not as often

I have a 1994 mazda protege dx 4 cyl. and i was driving one day and it just died out of no where. i pulled over and walked to the gas station to get oil, because i was low and thought that might be the problem, so i poured oil in and tried to start, it will make the noise like it wants to start but it never turns over. a mechanic tested it and said it was the engine coil, i paid 80 and got one and this was not the problem. I do have air in my car, ive read about an air flow sensor? i dont know what that is. a couple people said it might be the fuel pump also. Just trying to get some ideas.

I replaced the pistons due to loud knocking; replaced timing chain but not sure if it is correct. What should I check now??

when i restarted the car it acteds like it was going to cut off low rough idle lungin sort of like when car runs out of gas and you get it running.. new plugs,oil, coils,transmission flush, car was perfect for the first 10-15 miles drove since vandalized then all of a sudden it sounds like a sick john deer tractor with a flashing engine light..surges,idlesrough almost dies, continuously,, doesnt get better

I have an interesting problem that has me stumped. The car won't start with out a jump. The battery is new, the alternator tests good. The cables are not corroded. The fuses all seem to be good. I can usually start it once after it has sat for a while but if the engine is warm, it will not start. The engine does not overheat. There is no check engine light on. Any suggestions would be appreciated.

Mine is a weird one, turn key, car starts, then immediately dies, try again, but this time hit the radio power switch & everything is fine!!!!!!!!, also central locking does not work, other that that everything is good, car will run all day once started, like I said weird

So basically, I cleaned my throttle body about a month and a half ago, ever since then my car hasn't been running properly. I drive a manual, so the rpms have to be at a certain spot right? Well, they often drop and go up a lot and end up in my car stalling. People have said its the throttle positioning sensor, or the throttle body sensor, an since im not a mechanic, I have no idea. please help!

Mazda protege 1992 has no power steering been driving for a year had started to over heat shut off then wen turning back on I drove about a foot b4 I noticed staring wheel won't turn

I am a mechanic and not use to working on Mazda's. I recently have had problems starting the car. It cranks excessively before it starts. Once it starts it runs fine and I have great fuel pressure. I thought the fuel pump check valve in the pump was bad and losing the prime. But I noticed when I was removing the pump I turned on the ignition to check the pump out of the tank that it doesn't run for a few seconds to prime like today's fuel injected cars do, so I am wondering if it is the Fuel pump replay is malfunctioning. What is your ideas?
P.S. I went ahead and installed the new fuel and strainer pump since I had it out anyways.
Thanks

Mileage 130,000

replace rack and pinion system

have checked all fuses,and connections in the a/c system I worked on,checked bat. connections and all are good. checked for fuel and spark. I do have good fuel pressure but no spark

I put oil n all in it n put a brand new battery in

I dont get any gears. I take it the possibilities now are a powertrain control module... and ? Anyone anyone... buehler... buehler.
HELP ME SPOCK! Im desperate. Thanks

repair shop says I need two cylinders and a tune up and spark plugs and wires

Car starts when cooled down but not cold.after driven will not start till cool down..makes no noise when key is turned to start.

Car starts when cooled down but not cold.after driven will not start till cool down..makes no noise when key is turned to start.

I have error code 1569 on and failed emissions test again today. I have one more attempt to pass. 1569 is an error with vtcs solenoid. I have no idea what this is and how to fix it. Any suggestions and/or estimates I'm looking at to get this fixed so I can pass emissions? I'm on a very tight deadline! Please help!

I need an answer asap for emission testing.

was told by my mechanic that I needed one becos car is/was not changing into third gear.........hmmmmmm