Mazda Mazda6 Questions

Answered Mazda Mazda6 Questions

Ask a Question
View:RecentAnsweredUnanswered
my car has had a new starter, alternator, and battery installed in it. It will turn over, but will not crank. When I turn the key to the on position I can hear the fuel pump and it seems like it has enough pressure. w...
i drove my car to a few places with no problems. stopped at a store and shut it off. went in to grab a coffee and went back out to leave. car was off for about 15 minutes. went to start it but when i turned the key my...
Wen I pull away its driving, the moment it must switch over to second stage it went in to a high rev,the car won't move, than my lump light go on, I replace new gearbox oil but it still do that, please help me what t...
But it also struggles when i get below 1000 rpm. What is the most likely issue?
I removed my head unit when I put it back in all of the following stopped working: LCD screen display, head unit, climate control illumination, and my defrost and a/c. I have already checked my fuses 5 times over.
also engages gears harsh when accelerating or decelerating this only seem to happen once I've been driving for more than 30 minutes. Do these transmissions have solenoids?
When it snows or rains. Have replaced windshield and ruled out leak coming from firewall and hood release
Ok, there are two things that went wrong, that lead to my mazda not starting. the gas gauge started reading a quarter tank when completely run out of gas. then a few weeks later it read 1-1/2 quarter tank of gas when...
distinct 1-3 second lag sometimes when I accelerate from a stop, especially when engine is cold, or when turning a corner. I suspect a fuel line filter, or fuel pump glitch.
When I started by car this am, the engine sputters for a bit then stalls after 20-30 seconds. Also, when I press on the gas it doesn't "rev" at all. Is it something with the transmission??
The check engine light continues to show. There isn't anything wrong
it keeps popping off i have to hold it so that it trickles into the tank
First code was P0401 (insufficient egr flow) had it cleaned, where there was very little carbon build up. A couple weeks later light came back on, but then went off the next day. Two weeks after that light comes back ...
Apparently fuel pump isn't getting power... All the fuses were checked - those that were burnt were replaced and checked again All the relays are working (based on the fact that they were placed elsewhere and checke...
Took my car to Midas and they said I had a bad transmission leak around the pan and they quoted me 210$ to fix it. Then a short time later called me back and said my car had a different type of transmission that requ...
I own a 2003 2.3L European JMZGG 166HP Hatchback Mazda 6. My engine's nikasil coating is damaged after putting chrome plated piston rings in 1000 miles. I'm willing to avoid this problematic engine with its balanc...
change the tcm. code u0073.After no code present. but same problem is there.
I have a U0101 code loss of comunication with the tcm, where is it located and what would be my problem
It has 3 not ready checks: catalyst, evap sys, O2 sensor. I installed a new battery about 3 months ago, before that I had to jump start the battery a few times. Since the new battery and the initial inspection, I've ...
I just changed the plugs and fuel pump. The car once put on gear does not move