Kia Rondo Questions

Unanswered Kia Rondo Questions

Ask a Question
View:RecentAnsweredUnanswered
After taking a fairly short drive (less than 5km), the ignition would not shut off, even after removing the key from the ignition (which was in the off position). I switched the ignition from "lock" to "on" multipl...
I turn the key n the radio n lights come on the gages move a lil but the car wont start after letting it sit for hours it started right up but the dealer i bought it from sy the battery starter n alternater is good so...
This is a car accident situation We don't feel we can trust our KIA dealership They were very much aware of the air bag malfunction within the 30 days of purchase and nothing was done Several weeks ago an accident hap...
Do I have to buy a whole new compressor when it is just a faulty clutch?
I hear a sound like pounding something when I drive on the unsmooth road. Is it possible to get suspension parts of Rondo? Is it possible to replace one of the parts separately? For example, if the damper has broken, ...
My car is a 2009 kia rondo and acts like tranny is slipping, tech says just dirty transmission fluid
For the last few months I have noticed the air would suddenly blow hot for no reason, then come right back to cool. But more recently, it is blowing hot more often can cool. Restarting the car does not fix it. It just...
when i change the battery the odometer reading changed from kilometer to mile so how i can but it back to kilometer please
I am having problems locating it. i see on the left valve cover(closest to the front of the car) a kinda looking like but not it
I have tried to twist, pull or push the tiny bulb with the needle nosed pliers and it doesn't budge. The auto shop gave me the bulb and said all the work is in the labor. I'm beginning to think this is true.
what could cause this? Also, it's sluggish on pickup speed and now the steering wheel vibrates when going faster than 65mph. Also, the car seems louder than normal. Are these all related or separate? thanks!
get a diagnostic check they found no leaks everything was good. Ask another person they said it's the low pressure switch so ( where is the low pressure switch located? )