275
questions

I parked my car yesterday and then tried to start it and it would only run for a few seconds and it ran rough those few seconds. The check engine light and battery light was on during those few seconds. I don't know technical stuff but also the fail safe engine mode light was coming on at certain times but the car was running great until yesterday.

engine light on all the time. Restrictive performance goes on and off.

It is a toggle switch that seems to engage disengage on it's own. Driving and turned off. There is no fuse for this. This has been a small problem until now. It just seems to get worse.

I had crankshat and water pump and new battery hard to start and will not start

I did not hear a thing. Car just would not start. Now, need whole new engine. WHAT!

The person I bought it from states it use to work. He stored it at a friends house for a while and when he returned it the trunk would not open. When I push valet on the dash it shows valet mode. When I push the trunk release it shows valet mode as well.

The person I bought it from states it use to work. He stored it at a friends house for a while and when he returned it the trunk would not open. When I push valet on the dash it shows valet mode. When I push the trunk release it shows valet mode as well.

I replaced fusebox, fuel pump, relais,!!

My 2005 xj8l cintinue to pull while stopped at stop sign while still in drive? on another occasion I had to release foot off brake and allow vehicle to drove forward.If someone was in front of me I would have hit them from behind. this happen twice in last 2 months. Does any one know of any recalls or what needs to be repaired?

while still in drive? on another occasion I had to release foot off brake iand allow vehicle to drove forward.If someone was in front of me I would have hit them from behind. this happen twice in last 2 months

ENGINE HAS RESTRICTED PERFORMANCE LIGHT ON

you test the system to locate problem i did hear air escaping at the left rear when car was turned off and i noticed the dust cover is split on the rear shocks

For some time now, my car is showing a constant amber warning light for the airbag. Is this likely to be real fault or a fault on the circuitry? If it is the latter, how can I reset it?

CAR STILL DRIVE'S FINE

I'LL TURN OFF CAR TURN CAR BACK ON LIGHT GOES OUT NO MAJOR PROMBLEMS JUST DON'T KNOW WHY EMAIL RIVERSRONALD53@YAHOO.COM

How do I correct or diagnose

Did I blow the engine

What would be the first thing to do before starting

turn the car off a minute and start back up light goes out no major problem just curious

the car has been siting for a while- the battery when boosted lights come on..but the starter just clicks...

I was driving home a month ago and noticed my power was cutting out and it would die and I had to jump so I found out the alternator was bad. I havnt had the money to get it fixed until now so I figured if I charged the battery it would still at leist start but when I turn the the key to start it makes a sound like the starter is engaging on the flywheel and it turns all the pullies in front of the block but only like a quarter of an inch and that's it. does anybody have any sort of diagnosis for this?

I am trying to replace the ecu on a 2004 xj8 jaguar

i removed everything but it wont budge

after starting car up went about 4 miles radio went off and on then completely went off..windshield wipers stopped...transmission fail warning came on messages then completely stopped had to pull off road with everything dead...would not restart..had towed home on flatbed..had to over ride gears to neutral to get on tow...???? I just purchased 1 week so discouraged...ty for any help

i took it to a mechanic and he replaced the firing senssor and the engine computer and still it does not work.
the engine will start rough but it is not locked or it does not overheats.

on board conputor reads restricted performance plus yellow light displayed not red light

yellow light displayed

my 2004 jaguar xj8 stalled after going through power car wash and then wont start

Replaced bulb but that didn't fix anything. What could it be? Bad relay maybe?

how do you remove and install new front sway bar bushings