Isuzu Rodeo Questions

Answered Isuzu Rodeo Questions

Ask a Question
View:RecentAnsweredUnanswered
What else can cause poor gas mileage OTHER than; low tire pressure, old fuel filter, old spark plugs, dirty air filter or and bad driving habits? All these things checkout but my truck still only getting about 16 mile...
Wanna add a 24oz. Lucas oil transmission additive to my tranny. The fluid level is good where its at. Do I need to drain some to make room for the bottle. Directions say "add to existing fluid". Worried about overfil...
I called around some said motor oil others said automatic transmission fluid. It look and smelled like gear oil came out of it.
The other day at a red light the vehicle shut down, in trying to restart I got nothing not a sound. AAA came and tested the battery which was fine. My mechanic is baffled, he manually stated the vehicle and checked th...
what would cause a rough idle what would cause lost oil to the tone of 2 quarts every 4 days w
Is brand new and I charged it up just to make sure that it wasn't dead and nothing works my power locks don't work and when I put the key in the ignition my gauges won't work and I can't even get it to click . I also ...
i just replaced the master clutch cylinder and the slave clutch cylinder as well the whole complete clutch. the problem is that when i drive it for a long while it loses engaging power. i think something is not allowi...
I have changed plugs wires cap rotor fuel filter timing belt when I get up around 70 mph it starts to get a miss used to be mainly going up hills but is now more frequent. It did this before I changed everything.
I have a 99 rodeo an I put a timing belt on an reset the timing but now it will turn over slowly like the battery need charging but it a new battery if anyone can tell me anything I thank you.
When trying to start ,car starts Warnings lights come on ,no acceleration and stalls shortly after , had the crank angle sensor and alternator replaced , car will only start if alternator is disconnected , once start...
We had a flood out in aberdeen washington. water got up to the doors on the rodeo. Now he runs rough and almost refuses to accelerate quickly. if i don't ease into the peddle he starts to bog down and around 2500 rpms...
just want to start off with I have replaced the starter and battery already. It does not want to turn over sometimes after small trips. long trips it does not seem to have this issue. it will not even try to turn over...
checked alternator; its ok, bought new battery; drove for a day and the battery is dead, something is draining it.
not work. how do I fix the problem? cost of repairs?