Isuzu Ascender Questions

Unanswered Isuzu Ascender Questions

Ask a Question
View:RecentAnsweredUnanswered
I have a 2007 ascender. My vehicle service stabilitrak message lite stays on permanetly
when I press on the horn to long it will blow a fuse
when I try to sync it "pops" out after the on/off cyle and will not respond to the fob. The rear deck wiper and washer do not work and may have begun at the same time. My research indicates that the BCM may need to ...
I think it might be rain related but not sure. My rear washer motor leaks and it sounds like a pully is starting to whine. Any connections? Gonna wash it tomorrow. Thanks folks, happy holidays! -J Mark
Replaced plugs, Replaced cam shaft, crank shaft sensor and battery
my heat and air wont come out but the moter runs
I also think it's the ignition or starter. It has power so it'd not the batt. But stranded and can't get it started please help .
I'm thankful to find this site. Everything described here is what is happening with my Ascender. I can't drive it for fear of getting ram when the truck pulls/jerks/shifts and slows down. Am now hopeful I can get my ...
There is a hole in the top
when i turn on the heater it turns off the engine i replaced the map sensor and it is still doing it can someone help please .?????
seals and retainers were replaced a few months ago. steering box was leaking heavily and car was used frequently. after replacing the seal, leaking stopped, pressure was normal. now the steering wheel turns freely wit...
New Battery...new fuelpump...had oil in spark plugs but put new gasket in...idk
The a/c can still produce cold air, when driving over 50mph, the windows can even be rolled up. But A/c will not blow with any strength. The window on the passenger side and the overhead lights are intermittent. Could...
Problem just started, neater fan does not respon to any controls, but continues to run even when engine is stopped. What size are the screws that hold down the cover on the fuse/relay cover? I cannot find anything t...
On the highway, steady driving slowed down to pay a toll and all gauges went crazy. Gas didn't move and Temperature stayed the same. Im going 110 at a dead stop!
check engine light on, abs light on and red light with exclamation point on. Speedometer not registering back to zero when stopped.
Is there more repairs that are needed after the module has been repaired
I have checked the charcoal filter, and the little filter on the sylanoid and both seem to be working fine
Where is the oil filter located?
and if so where is it located or could b that its a bad battery plz help thx