Isuzu Questions

Answered Isuzu Questions

Ask a Question
View:RecentAnsweredUnanswered
paid 5oo plus and two weeks later oil light on took back thy say engine ruined . no problems with engine or oil before had oil changed month before!
My car seemed to drive okay on the way & when I arrived. At lunch time..started my car & the light has not flashed again, even on the drive home. Should I be concerned or do I need to follow this up? Thanks in advance.
After that, i'm oblige to cut the contact and leave few seconds befor restart and the problem is still present.
I called around some said motor oil others said automatic transmission fluid. It look and smelled like gear oil came out of it.
The other day at a red light the vehicle shut down, in trying to restart I got nothing not a sound. AAA came and tested the battery which was fine. My mechanic is baffled, he manually stated the vehicle and checked th...
what would cause a rough idle what would cause lost oil to the tone of 2 quarts every 4 days w
replaced it because key would not rotate. now the new lock cylinder is not killing the engine when shutting of the key. so i have to stall the engine and disconnect the battery so i wont drain it because the power is on.
My temp runs at about 195 but when I turn on the a/c it starts climbing up I shut off air at about 230 why would it go up like that
Is brand new and I charged it up just to make sure that it wasn't dead and nothing works my power locks don't work and when I put the key in the ignition my gauges won't work and I can't even get it to click . I also ...
i just replaced the master clutch cylinder and the slave clutch cylinder as well the whole complete clutch. the problem is that when i drive it for a long while it loses engaging power. i think something is not allowi...
What codes is it when the light flashes 1 time than pauses than flashes 2 times with the key on engine off. Than with the key on engine running the cel flashes 3 times pauses than flashes 4 times. Any idea on what the...
I have changed plugs wires cap rotor fuel filter timing belt when I get up around 70 mph it starts to get a miss used to be mainly going up hills but is now more frequent. It did this before I changed everything.
I connected the two wires and the cel flashed once paused and than flashed twice.
I have a 99 rodeo an I put a timing belt on an reset the timing but now it will turn over slowly like the battery need charging but it a new battery if anyone can tell me anything I thank you.