Should not the damaged seals have been identified in one of these repairs above l spent almost a 1000.00 and still have oil leak

1991 M30 Coupe, 70,000 miles, excellent interior and exterior, always garaged. Inherited car from 98 year old mother,
Car has always driven like it is brand new.

The ABS light, airbag light and check engine light all came on at the same time.
Mice had eaten some wires. Had a new ABS harness and a new engine harness wired in and the oxygen sensor replaced. The air bag light remains on-they can't find the code for it.

Had new ABS harness and wiring as well as new oxygen sensor installed. Engine light still on. Code was cleared after work was done.

transmission is not shifting and anti- lock brake light is on. Happened all at once. was working fine, next time went to start problem was there. overdrive light also don't work now. Also automatic transmission starts off in 3rd gear

I cannot lower the driver window by switching it...the passenger is ok...

Thank you

Is there a way to bypass the power switch for the seat.

in morning time-it will crank up and run perfectly fine and idols like dream-after a couple of revs-it will sound like it is rev llimiting and sputters till it dies and will not run again that day-this sequence happens every day. This is what has been done---starter replaced 1 month prior from this problem and ran perfectly fine. Fuel pump is working fine-fuel filter replaced and fuel pressure just fine. Spark plugs, spark wires,ignition module, iginition coil, magnetic pick-up has all been replaced--and still the same problem and gradually getting worse. The odd thing is-I put 3 different gauges and timing light on spark plug wire and when you turn it over-there is nothing and timiming light does not blink. When you take the spark plug out -it is indeed wet with fuel, when you place the spark plug and wire on to the intake manifold and turn it over-it shows great spark,the timiming light blinks,the gauges say good spark and the spark on the spark plug is bright blue. But when you place spark plug back into engine -it dows not spark, the timing light does not blink,and the gauges say no spark. What in the world can be happening? After new starter was put in----the car was driven from nashville to atlanta for christmas break with no problem. During xmas break--this all started. Daughter needs car for her nursing clinicals---please help.

they cut the wires of the stereo and the head lights are blinking and the car does not start, I can turn the switch but nathing happen. how can i disabled the antitheft alarm

The fuel filter is it located in the engine area or on the frame under the car.

Smoke coming from passenger door speaker. When a/c was turned off, it stopped smoking. But the smell of something burning lingers in car.

Don't want to pay a locksmith $185 to rekey ignition. Broke only key in half!Replacement?

I have a low beam headlamp only on the passenger side and a high beam headlamp only on the drivers side. I have checked everything I can think of. Good ground. red wire to the headlight bulb shows small amount of current on tester, but lights will not burn. I replaced bulbs.

In the process of changing a bad alternator, a ground wire was disconnected and came in contact with the positive battery cable. The car starts and runs, but no gauges work (also the alternator test gives me an "out of range" reading). I'm assuming I've blown a main fuse or fusible link, but can't find one that is bad (the ones under the steering wheel are all fine). Is there a main one by the battery that could be the problem? Your help in locating it would be appreciated!


where are the 3 spark plugs located on the driver side of the engine, i can only find 2 of them.

Our 91 M30 has a odd ac issue. The door granted needs adjusted, but the ac will stop working. Then my wife notices the door isn't shut all the way, so in shutting it the ac starts working. Driving down the road it will stop for hrs and then start working again. Relay of some sort? Bad ground?

steering issue, when turning you have to turn the wheel about a quarter turn before the car actually starts turning.

it will run but its got like a skip to it and white smoke coming out exhaust i put new starter on it and new battery

I have problem to start my car (1991 infinity M30) because of its anti-theft system. Is there anyway I can deactivate or disarm the anti-theft system of this vehicle? I DON"T HAVE A REMOTE. Is there a valet switch. If there is a way to disarm this "junk" please be specific step by step on how to cut it off. Thank you very much for your time.