Hyundai Questions

Answered Hyundai Questions

Ask a Question
View:RecentAnsweredUnanswered
Mechanic checked/replaced sensor. worked for a short time- now not at all. check engine light is now on all the time.
while driving you can hear a ticking sound.
car drove fine all day - cluch got hard and soft. Fluid levels are okay
I also replaced plugs and wires it bubbles up and runs hot. Why?
28in driver sider cv axle is clicking and needs replaced. Parts stores and dealers say 25in is the correct one. What would explain a 28in being used? The center part of the axle is even longer than the replacement 25i...
my 2006 Hyundai tuson just die on the free way with my kid and will not start but is trying I repace the fuel pump that cost 311,00 and still it trys but wont kick over help
At first the engine would rev high so I would shut it off and restart then would put in reverse and it wouldn't move or engage until giving it gas. Can you tell me what the problem is? Not sure if it needs a new trann...
egine and restart. The cel would come as normal and go out. My car would run fine. I took it to a tire shop and they checked it out. They replaced an o2 sensor and new plugs and wires along with a fuel system cleaning...
My car had engine light on and flashing took to change coils and cylinders on the way home started slowing down. Then completely went to no more than 10mph. Took back replaced fuel pump regulator now car won't go if y...
I replaced timing belt but still won't start. May not have lined it up right. Does this certainly mean my valves care shot?
changed alt and battery. and I am getting no charge coming from altenator.
Can I have the oil pan rethreaded or tapped out instead of buying a new one.
It staryed immediately after the jumping calbes were put on correct but once I turned my car off it wouldnt start again without a jump.
Engine light is on and code given refers to EVAP i already replaced gas cap the EVAP and selenoid and nothing
Anyone else have this problem and what did they do to fix it?
This happened after I replaced the old one after realising leakage from the cam..
This begun after there was an oil leakages from the cam prompting replacement of the seal... We have tried it over and over again but it still comes off...