The angle is too great and the CV axles break. Will a differential drop work? If so, when can one find this?

water is not circulating through motor

Burning to much fuel

My car runs, but when I press the gas it turns off. I've taken it to the mechanic and they tested it in a scanner but it detects different sensors at different times that is tested. Please help, I'm a woman and I don't know much about this stuff.

sunny weather car will not drive unless in 2 and not go above 30 mph. while on rainy days car drives perfect in drive. what can cause the problem?

seems like it tries to engage but do not go all the way in

My gas needle blinks empty even after I fill up. My speedometer doesn't work one bit and my mileage either.

does it in all gears I've replaced wires plugs fuelfiler oxygen sensor an airfilter any ideas does it always

How do they calculate the.parts and labor costs

Shift shaft seal accumulator seal & 2 pan gaskets. Honda quoted me $436

When i take off the timing belt cover, sometimes the belt is slack near the tensioner, sometimes it is taut...have already replaced the thermostat, and cleaned and flushed the radiator, and checked the cooling fan clutch

it just started today drove fine before went to put key in an lights come on but wont turn over dose not make any noise an it is like it is stuck in gear

whenever i drive and cut off the engine and try to put the passport on park it gives trouble and i havto try it alteast 3 to 4 times before it stays on park.also it wont start whilst on park and i havto bring it down to neutral in order for it to start plz help!!!!!!!!

the key doesnt want to go to lock and the engine doesnt lock

But the wires from the aftermarket switch are colored differently than the ones on the original?????

Have checked injectors for pulse with noid light. No pulse.
Have pulled and tested spark plug for spark. No spark.
Have checked codes - getP1290, P1299, P1295, P1515, P1220.
Replaced TPS and checked harness for continuity. All good.
Have replaced the crankshaft position sensor, had PCM checked by technician.
Still no start.
Cleaned and checked grounds, tested coils for voltage, tested injectors for voltage. All good.
Have unwrapped and inspected engine wiring harness for breaks.

NO START. Am ready to drag to auto auction.
Please help!!!

I can shift it manually but it is an automatic

Which is best for a South Florida climate?

Windshield washer, radio and some inside lights don't work. I think a main fuse must be blown. I have checked fuses under hood and inside. Where/what main fuse's should I be checking?

My reverse lights have become 2nd/3rd gear lights. From what I can find online, this is a common problem on older Passports/Isuzu Rodeos (same car), and on the 3.2L with a 5spd manual like mine, the sensor is $10 and is located "on top of the transmission". Can't find any more info. Could I get a decent explanation of how to approach replacing this myself? It would be a shame to have to take it to a shop for a $10 switch if I can avoid it.

is their some thing wrong with the brain that's what another shop I took it to said

It should go down to 0 but it idles fast. what is doing this. I replaced throdle cable and 4 02 speed sensors and h20 sensor and cleaned the idle control valve. what else can I do?

The timing is set and it well NT run it truns over like it wants to and trys to but well NT I just need help thank u

I have replaced the head,timing belt got it all in time still willnt start also put a new crankshaft sensor its got great fuel and the head has 175 psi on the compression what else can I check to see if it will ran

it was low on fluid so I added more fluid