Foreign wording(Japanese) the first two lines. Line underneath them says check cd-rom.

Just changed lights on the front and one of the round driving lights won't come on. Thought it burned out reason to change it but now wondering if electrical or fuses?

the speedometer acts erractily after stereo was stolen from vehicle

they are starting to fall apart and the rains are coming soon.

the speakers are blown out, what speakers do I need?

My front left tire pressure sensor had malfunctioned and is not reporting the pressure. What steps are required to replace the sensor?

AC blows on floor and windshield but does adjust to chest level.

It says to put in auto,but that don't work

No green light on right side of mirror next to emergency button. Unable to figure out which fuse to check so I have checked nearly all of them on the left side of the dash as well as under the hood. Bluetooth phone feature does work but On-star does nothing at all.

Dealer says several hundred to "troubleshoot" before any repairs or anything which I feel is kind of ridiculous.

my gears is shifting.

rear access window keeps popping up every time i take off the alarm or i open the back door

The unlock sounds like it's working , can't find anything to manually open gate

Okay so my brake lights aren't coming on with my led taillights. But they do come on with my lights set to auto however they do not with my lights fully on or with marker lights on... if I also changed the bulbs all to incandescent and everything works as it should. So what the heck is up with that? Lol also they have worked in the past up until now which tells me the led taillight might have faulted?

Changed the battery in the remote one it will only open the drivers door

And it say reduce engine power what does this means

no problems and high expense?

It sounds like aluminum cans in a larger can banging around. Even when the car is idling the noise persists. It is not usually there when you first start the car.

I have a lot of problems with my engine, and I'll make all the reparations myself. Please help me with a service manual. Thank you

My CEL came on. I took it to auto zone, they told me that it was my fuel filter/pump. I then took it to a shop and they said a fuel filter will not cause your CEL to come on. They hooked their scanner up to my truck, then told me it was my rotar cap for spark plugs (I think) and my o2 sensor. I've gotten the rotar cap replaced since they said I can go longer without getting the o2 sensor done. My CEL went off after replacing the rotar cap bit came back on 2 days later. Do I really need to replace the fuel filter or the o2 sensor? Oh by the way, the truck hesitates like it's going to cut off while I'm stopped at a stop sign or traffic light......any advice?? Please help lol

I have a 2006 GMC Yukon XL Denali

I have loud knocking from my engine after filling up with gas from a 7 eleven. Before I put that gas in everything was fine. After filling up the next morning when I started up my car it started knocking. Then the check engine light came on indicating a misfire in cylinder 4. The knocking gets louder as I accelerate. I have checked the spark plug and cleaned the rockers and lifter tubes. It still knocks and check engine light is still reading misfire cyl 4

I'm not sure if the denali I bought used, has all the cats it's supposed to have. I live in Cali. and am having a hard time smogging it. Thank you in advance for your help

Tried to make to get gas, cut off at light didn't make it no gas. I then

you can touch buttons and they don't turn on. both front passenger and driver side. along with back seat heated seats.

the light with the little person sitting in a seat with air bag in front of it. has been on since I purchased the car.

I replaced rotors, upper control arm, pitman arm, idler arm about 1000 miles/6 months ago. Replaced brake master cylinder about 9 mos ago. Replaced power steering hose (turned engine on in process / degreased after replacement).
Immediately after degreasing, serpentine squealing warranted replacement of belt, idler & tension pulleys. A day or so after replacing the belt & two pulleys, I noticed idling mph impeded and coasting distance to stop affected. Total of 2 miles driving over the next two days and I brakes were engaged to the point that I chose to drive in 1st gear for the two blocks to my house. Replaced caliper at the suggestion of my auto parts sales/service rep. Brakes were fine for about ten pushes and, then, locked up again. Both sides smoking in the cold air (and smell of overheated pads big time). Frustrated and am praying for some guidance to most logical order / procedure to troubleshoot the source(s) of this problem. Thank you in advance for your consideration.

the defrost comes on but wont blow if u change to feet or anything els the light flash then all will shut off or do nothing at all not sure if its electrical or something with the blower motor . the back heat does blows but only cold the the truck is throwing a miss fire at 4 and a o2 sensor

When readiness monitors reach 100% ready, ses light comes back on and throws codes po420&po430.could timing issue throw these codes or does it have to be bad cats?