Close

GMC Yukon Denali Questions

Get answers to questions about your GMC Yukon Denali at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
468
questions

its under the dashboard on driver side and also hooked up to the security system?

What does zero hours mean? Is that why my truck won't start? All fluids are full at the time.was only driven 10 miles per hour .was no warning lights telling me of any problems. Took my truck for regular schegdual maintainance and they power washed my engine and causing electrical problems. So had to keep my truck for two days and tried to fix it.720 481 5694 michelle

What is this? what does it do> why is the light on?

Just started about a month ago

It won't work the radio does work at the navigation CD when I come out when I hit the eject button

Says stability sys disabled since I changed rear brakes and rotors, has never said that before, what happened?

i was told take a drive cycle??? but the sensor has not ever been changed??

The exterior passive lock/unlock buttons on the doorhandles of my Yukon do not work. They work fine on the passenger side, however on the driver front and rear door they do not work. I have change the handles but this did not fix the problem. Have also change the fuses. Any suggestions?

Unplugged switch and checked for shorted or bad wires, still runs. Any suggestions?

It comes on and off while driving and while driving you a noise that sounds like the brekes are scrubbing

looking for cost and service in my area 85014

Both rear struts failed at 20,000 mi, front (RHS) failed 30,000. mi. Rear grinding on open road causing me to limit speed under 30 mph. Front is grinding with any bumps in the road, particularly smooth speed bumps at slow speed.

The cruse control will not work. When you try to set in it will not work.

When the vehicle is unlocked, the mirror continually folds out instead of tilting to the proper position. In reverse, the mirror assembly constantly, repetitively, and slowly "clicks" to the curb side view. The same will occur when the vehicle is placed in drive and when the mirror attempts to return to its original position.

Gas Guage worked fine and was always accurate until I changed the fuel pump out and now it isn't working at all

Car has ran fine until now. I dont know if its a bad fuel pump or electronic module? Any help?

Foreign wording(Japanese) the first two lines. Line underneath them says check cd-rom.

Just changed lights on the front and one of the round driving lights won't come on. Thought it burned out reason to change it but now wondering if electrical or fuses?

the speedometer acts erractily after stereo was stolen from vehicle

they are starting to fall apart and the rains are coming soon.

the speakers are blown out, what speakers do I need?

My front left tire pressure sensor had malfunctioned and is not reporting the pressure. What steps are required to replace the sensor?

AC blows on floor and windshield but does adjust to chest level.

It says to put in auto,but that don't work

No green light on right side of mirror next to emergency button. Unable to figure out which fuse to check so I have checked nearly all of them on the left side of the dash as well as under the hood. Bluetooth phone feature does work but On-star does nothing at all.

Dealer says several hundred to "troubleshoot" before any repairs or anything which I feel is kind of ridiculous.

my gears is shifting.

rear access window keeps popping up every time i take off the alarm or i open the back door

The unlock sounds like it's working , can't find anything to manually open gate

Okay so my brake lights aren't coming on with my led taillights. But they do come on with my lights set to auto however they do not with my lights fully on or with marker lights on... if I also changed the bulbs all to incandescent and everything works as it should. So what the heck is up with that? Lol also they have worked in the past up until now which tells me the led taillight might have faulted?

Changed the battery in the remote one it will only open the drivers door

And it say reduce engine power what does this means