159
questions

I have a 07 Canyon with only 51000 miles on it and I have another 2000 miles to go before i need an oil change and my truck is bone dry. I do not see a leak. Has this happened to anyone or what I should do?

The codes recently came up but I have no problems with the operation of the truck.

The light is illuminated, and the rear flasher works, and it works inside, but the front left will not work.

the anti-theft light has been playing games for 2 weeks now. now the light is always on and the truck will not start. tried some of the suggestions that have been posted. i cant even get it to a dealer if i wanted to. it also has a viper system in it for remote starting(came with it,bought truck used). needless to say that doesnt work either. now what? options?

my brake lights quit working and i think it might be a fuse

I have found where the leak comes from. Its from the Pipe, fuel feed (To Tank). Fuel Feed is connected the Fuel Pump. Fuel moisture is visible but no fuel dripping identified, strong order of fuel on driver's side. It looks like someone tried to pulled it out. I have searched the part # on GMPartsNow.com and it is listed Part No: 777770.
What is the cause of this:
Estimate cost for repair:
Is the Fuel Pump in any damage now:
Any suggestion please. Thanks.

Changed fuse box and head control and resister

Stalling happens when vehicle has been driven for a while or sometimes when idling for a bit, pulling up to stop signs or lights. I have had it to the shop twice, no results as no codes. Odd thing that happened recently..fuel gauge registered 3/4 full one minute then not long after registered 7/8 full, how can it go up, vehicle was running both readings, does this have anything to do with stalling?

2005 GMC canyon, no electrical power at all. got out everything was ok. got back in turned key no powder, just clicks, no interior lights, no power locks, nothing. Please Help!

has happened 5x. Shops have diagnosed it, cannot find why. has gas, plenty cranking power no go. After 30min. it starts. Other times no, tow truck to shop. They said the same thing, but cannot find out why,
Should I just get rid of it, problem solved or do you have any
ideas.
Your help greatly appreciated. Diagnostic check, did not show anything.
mike

Its been happening more lately and can't find a fix. Anyone else having this same issue, could use some help. Thx

It worked then it would shut off, then I turned it back on and it worked for a few more miles then went off again, then wouldn't turn on at all. I had no warning at all. The only other issue is that sometimes it will shudder & try to stall as you come to a stop.

System will work fine for weeks, then it will activate 1 to 3 times per day.

If I wait 10 minutes it will start. Is this a dealing only repair and approx.how much will it cost. Thanks hope to hear from you.

The change oil light is still on after the oil change. Wht won't it go off?

3006 GMCcanyon.

the heater blower switch only works on high how do u replace it and where is it located

I will drive and the temp gage will be normal, then when i shut it off and come back in a few minutes the gage will read hot

I have used an OBDII code reader when the Check Engine light illuminates, but the reader shows no codes. I reset the light, but it comes back within a minute of re-starting the engine. When engine is cold, it "bogs down" upon acceleration, then picks up and operates fine. No noticeable change in gas mileage. This has happened several time in the past month.

need the location of this part and how hard is it to fix

i do some mechanical work and fill i can fix if understanding were and how hard it is

Shop says it is a plugged radiator and that it cannot be fixed but must be replaced at a cost of $800.

Fuel gauge failed, but fuel pumps works. what is the cause?

after awhile it goes good. it a 2.8 in 2 door canyon. what could be causing this to happen or is it normal

I have a 2005 Gmc canyon that keeps losing power and i don't know when it's going to do it.I have a son to protect and we were almost hit as my truck lost it's power in a blind hill yesterday on the way to their school!Thank God the car swerved out of the road & everyone was alright.This was a wake up call!I have already paid out hundreds of dollars on having it put on a machine & being told it was the throttle body,so i had it replaced & thought it was fixed til it started with the same thing happening again which is 2 lights come on saying reduced power and traction default-idles badly!!-and loses all power,but still runs?I pull over to a safe area then turn it off and on a few times and it's fine.It is getting worse though by doing it a few times before i can get back home.Can anyone please help me?My husband has posted asking what could be wrong,but no luck yet.Anything would help.Thanks

My 2005 Gmc Canyon has been losing power,idles rough,and a light saying reduced power and traction default.I took it to the shop and had them put it on computer that pointed to be the throttle body so i replaced it and it didn't fix the problem.I got a response yesterday from someone telling me it was the pedal sensor and module at fault.I tried responding back to ask where the sensor and module is located and does this mean the control module or which module?Any help would be greatly appreciated.Thank you.

I recently took my 2005 GMC Canyon(87,000 miles)2.8L 4 Cylinder to the shop to be put on a computer that pointed to my throttle body because,out of the blue it loses power,idles very rough,and the engine light saying reduced power and traction default comes on when it starts acting up.I replaced the throttle body and it is still doing the same thing it did before putting a brand new on.I can pull over and turn it off and back on several times then it starts running normal again,but not for long til it starts acting up again.No one has no idea as to what could be wrong.Please help!Anyone out there have any idea's?I would greatly appreciate it.

Screws are hard to see don't I don't know size

Items checked no oil in radiator,no oil under neath anywhere on either side or on top of engine,no smoke, and no oil in tail pipe.it will only happen if you change speeds signifantly (example driving 65 pass a car accel to 75 then resume back with in 20 to 30 min engine oil light come on and 2qts are gone and no sign anywhere.)motor still runs just like new no power lose,i am the only one ever to drive,no kids ,hot rodding just mainly highway sometimes to town, and it has always had valvaline 5w30 put in at every oil change.i have had a few other problems but nothing i could not handle.example some times starts some times just cranks-ignition wore out,misfire code-gas pedal and throutle body,just cranks no start crank sensor,tail lights shorted out,grinding in front end-sealed wheel hubs,forward motion only grinding from rear-roll pin in rear end broke,a/c only works in one position-board behind switch is going out,driver side window switches will not work-remove panel take switches off and remove dirt from contacts that fixes those but this has me stumped any ideas or anybody heard of this problem.

What is the spark plug gap setting for a 06 GMC Canyon?