Geo Tracker Questions

All Geo Tracker Questions

Ask a Question
to the point that I have no pedal. Its not the emergency brakes, cause I checked, its definately the front brakes. what could be causing this?
It rusted to pieces along with the bar in front of the tank plus so r the shock towers what do i do to fix all this?
when the key is turned on the headlights don't go on as they always did in the past
Found a tail light parking light relay,also found one headlight relay did locate a seperate relay for high beams
Power at the bulbs all three wires turn on lights the middle one goes to ground turn on high beams all wires hot again is it the switch ??
I was driving down the road and it lost power. I kept driving and it regained power only to loose it again. I pulled over turned it off and it wont restart. I thought it was the timing belt replaced it . That wasn't t...
My speedometer works, but the gas, rpm, and the hot/cold does not? wat could this be?
before that, it would slow down even when i was pushing the gas all the way. i would let off then it would speed up a little, but slow down again. went to go up a hill and it completely shut off. tried to stat it back...
I know if it is not broke don't fix it. But, I bought the 94 tracker, it ran well, but a little rough. so, i put new cap, rotor, wires,and coil in it and now it sputters, idles rough for a few seconds and will not sta...
My 96 geo tracker has to be push started to get it started, it's not the starter, I've replaced the clutch cable. Don't know what else it could be. Would the #1 spark plug have anything to do with that
Will go into gear when engine is off but not while running is it my clutch or trans?
It all started one day after I got home from work and cut it off! The next day it wouldn't crank! I changed spark plugs and gas fuse under da Shower!
I have power and everything, what could be the problem?
It shifts great otherwise. It just downshifts when I am trying to maintain a steady 35mph. it drops into 2nd gear from 3rd gear. It is a 3 speed automatic. Fluid level is good as is the fluid. What would be the likely...
It's not throwing any codes other than the 12 code I pushed out left it sitting for a few days came back it started I drove it into the shop and it died but now it won't even try to start it like there's no spark timi...
when cold it does not want to shift out of 1st.it is automatic.when warms up shifts fine no slipping.fresh trannny fluid not burnt or smelling funny.very aggravating my have to wait 10 min. to warm up.
Is it possible to put the manual trans. in nutural and manually press the safety switch to start the engine to take to the shop? They told me the last time they adjusted the clutch cable that it needed to be replaced.