Ford Windstar Questions

Answered Ford Windstar Questions

Ask a Question
View:RecentAnsweredUnanswered
Van is misfiring
Replaced engine. Ran great. Now won't start and have to unhook battery to get lights etc off. Replaced ignition switch
Often, when driving, I turn right (mostly) the wheel will turn but the tires wont. Even when going straight but turning on a slight curve in the road. The slipping is not every time but happens at least 5-10 times a d...
I have been trying to fix this problem now for a while and can't seem to figure it out. I have changed the coil pack and all plugs and wires. The miss hasn't changed or moved at all. When I am going down the road ever...
when I accelerate while driving, my transmission shifts real hard I was told it could be the speed sensor does anybody know any solutions could it be the speed sensor or am I going to have to replace my transmission.
I own a 2002 Ford Windstar. I need to replace the positive battery cable but I can't because the power cable from the alternator that plugs into the positive battery cable must have broke for the previous owner and h...
Could you send an instructional picture.
The two fans by the radiator quit working and when i drive long distances or in stop and go traffic, there is smoke that comes from the hood on the drivers side
My winstar has the airbag light on if i take fuse out will it deploy?
p0302. changed coil, plugs and wire so far
Just bought this vehicle. It has been well cared for but it came with no maintenance history nor even owner's manual. Wondering about maintenance schedule repairs such as timing belt/chain replacement or other issues ...
And then comes on when idling, Would changing the oil sensor unit correct this problem
Had no problems with it just pulled in driveway and tried to turn around and I had no reverse or any other gea
Sputtering when taking off, smell of gas, higher rpm's when pushing on gas pedal.
will it bolt up?they r the same engine,bolth 3.8 fwd can this be done?and r their any differences.
New struts and shocks were installed about six weeks ago
My heat is not working, I would like to use 12 volt defrost/heaters.
After driving for about 10-15 minutes on cold (Less than 32 degrees), days, my heat gauge goes very high for a few seconds and then back to normal. It doesn't do this again unless the engine gets cold again. When thi...
While accelerating the van will make a squelling sound and the van loses power. The motor doesn't die but it feels like it disconnects from the transmission. (( I'm not mechanic )) and will grab a gear a moment after ...