have Sport pads with standard rotor. Pads seem to large. They extend up past the rotor, and are grinding on hub of rotor. Pads fit on sport rotor, which is taller and has a smaller hub. Problem there is sport rotor is to large to fit caliper bracket. What's up?

1977 tbird

I have a 97 Thunderbird too, and am having the same trouble. Hard to start and runs with a bad miss.
When I put it in gear it misses very bad and the engine sounds like it is about to through a rod. Rattles like crazy.
Has new plugs and I have been told it has a sticking valve. I added an additive to free up sticking lifters. Tomorrow I will
check the compression.
Does someone have any idea's on a fix?

As it warms up motor runs roughly and smoke and then after moment it dumps bunch of oil I hear what sounds like.vacum leak also it also seems like it's going through lots of gas

How can I repair this problem?


I can't g my o/d button to work on my 97 t-bird. The light doesn't come on either. Does anyone have any idea what the problem is?

My Tbird was running well before the replacement of the alternator, battery and the vale cover gasket change. Mechanic broke T birds throttle's so he replaced it with a early 2007 crown victora

my trans stoped pulling first the o-d light started blinking when the car got warm and I had to let off the gas so the trans would shift into drive and now it will not pull in drive 1 and 2 are fine. could it be an sensor

it tries to go into drive but it seems like it isn't fully going in when the o-d light first started blinking I had too let off the gas so the trans would go into drive

I can get up as fast as needed in regular drive but the o.d. won't kick in at all whether dropping the gear or picking up the gear and runs fine until approx. .30mph then I've gotta shift to just drive if I wanna speed up and not rev the motor and go nowhere. fluid is clean and fine

can you tell me how many hours of work is involed total

I was driving onto the freeway ramp when I heard a clink sound. In seconds I started hearing my pistons clanging away because of the lack of oil. I may have striked a rock or something. I'm not sure. All I know is that it still starts but all the oil spilled out. Can someone please give me an idea of what went wrong?

I've been hearing a strange noise when I start my car and when shifting gears but doesn't happen all the time also car stalled for the first time today and engine light came on for a while then shut off and sometimes when I start it it feels as if it don't want to stay running anyone have any advice or have the same issues an what should I do?

Was running great. Cranks fine has fuel won't start .

There is a ride control button in my 91 t bird. The struts and shocks I bought won't hook up to that. Is it ok to use them?

On occasion, a warning light E appears. the transmission seems to perform OK and the light disappears.

It will eventually start after cranking it long enough for the check engine light go off and the fuel pump fills the line with pressure. It will also start if starting fluid is squirted into the throttle plate assembly. I replaced the fuel pressure regulator, the problem still exists.

The back light and the dimmer do not work. all gauges function properly but night driving is not possible. vehicle only has 50 340 miles