574
questions

When accelerating the truck often begins to shake or vibrate violently. Generally, not on cruise control though it may be happening to a lesser degree when on cruise. If you immediately let up off the accelerator, the vibration eases off but it you continue to push accelerator it gets much worse to the point that things in the truck and trailer fall, spill etc. (6.7 diesel engine)Since it is not reproducible in the shop, no codes have been identified.

Cleaned the sensor it started shut it off started up tryed starting a hour later won't start bought new sensor won't start. Any idea's?

no power and stalls out when driving

It started one day when I was on the interstate doing about 75 and it started right back up and didn't do it again until a few days later once again I was on the interstate again I was doing about 75 so I thought it was a problem when I go over 70 but know it have gotten worse it seems like if I drive it and don't push on the gas so the rpm don't go over 2 grand it won't kill I had the codes read at auto parts store and it said I had a bad crank and cam sensor so I changed my fuel filter and both sensors still have the problem any suggestions

I have an F350 Power Stroke. I have had it into Ford 3 times over the last 2 MO. I just drove it from Las Vegas To SLC, it pulled great up the hills NO problem. I just picked it up from ford 3 days prior to leaving town. On the way back home it started the same thing that I have had it not ford for LOSS OF POWER! would only drive 54 MPH.

I feel like I am a Ginny PIG and they are doing trial and error to fix my problem. $1500.00 and I still have the same problem.

The truck does NOT do it all the time, just sometimes!

HELP! Any suggestions or Ideas?
Now they are telling me another story and saying it is going to cost just over 6,000.00 to fix!

HELP! thank You, Richard

I just put a camshaft position sensor in this truck and it still shuts off while I'm driving it so what's the matter with it

I just need to know what are the major pieces to remove and reinstall a rebuilt manual transmission I know the drive shaft the shifter the slave cylinder starter have to be removed and the crossmember but I was wondering if I can swap it out without having to remove the exhaust

This only happens when the truck is parked on slant, bed down hill for about 4 hours. It will start right back up and repeats this until I start it and immediately hit the gas pedal. 6.0 diesel.

I changed both of my fuel filters and that didn't fix my problem

i have been threw everyhing on the top of the motor repaired or replaced. the truck will pop if u spray wd in intake but i do not see the turbo spinning or am i getting any smoke while trying to start the truck like i use too any sugs.would be great thanks

It has a leak around the bellhousing. and the engine has 219000 miles. i lose half a quart after a week of driving

I have a f350 V10 and after you drive it for alittle bit and the truck heats up and it starts to bog. catalytic converters were just replaced so was the whole exhaust system. All sensors were replaced too. Fuel pump is relatively new and new engine was put in this past winter. When you scan it no codes come up. Electrical was just redone also.

passenger front wheel chatters when stopping but not all the time but even on dry roads

My husband is driving his truck a 2013 Ford F 350 Superduty when the Information Center on the dash behind the steering wheel only displays half the screen and it is very small. Is this a fuse or where can I start looking to fix this.

Truck has 66000 miles . When driving down the road truck seems to taking longer to shift .when letting off the pedal to let it shift it sometimes will make a backfiring sound . But i have noticed that when accelerating the turbo seems to not be working . This doesnt always happen everytime there are times it runs fine but here lately its more frequent does anyone have any suggestions where to start dont have alot of money to take it to the dealer . Forgot to mention the truck does sit alot

After recharging the A/C it still blows warm air. What else can I do to solve this problem.

the pump sets behind the cab. solenoid, one line in and one out with a little plastic red box coming in front of return line I believe, does any one know if that is valve to realese box to come down?

Drove home from dealer after having complete checkup and telling them about this issue. All tests checked out fine. 1 hour into the drive home it shut off again like it was starving for fuel. Sat there for a couple minutes cycled the ignition then cranked right up and drive about 2 miles and as soon as I went into idle it conked out again. Any ideas??

Truck will not take gas just idals

service engine soon light need to plug in code scanner don't see plug

The truck studders at 45-50 mpr and looses all power and just shuts off , when it first started doing this I took it somewhere and they Said my crank sensor was bad and my ficm harness was shot so we replaced both now it's doing it again less then 2 months . Help im a single mom and don't want to kee having my truck quit me

my truck overheated and i found oil in the
rtadiator

my truck overheated due to water-pump failure after I replaced it I have steam coming from the exhaust. have been told that I may have (1)blown head-gasket(2)cracked head.(3)bad egr valve. have removed the egr valve and it looks ok to me. will a non functioning egr valve cause my problem or do I need to look elsewhere? is there a way to test it?(its electric)