574
questions

I have encountered a problem with white smoke emitting from the exhaust in my 2000 F550 chassis v-10 engine motorhome. Head was actually leaking antifreeze through the casting and into the exhaust. To replace both heads with parts and labor I paid $7560.49. This seems crazy expensive to me. Their shop rate is $112.00 an hour and quoted 34 hours to perform, parts totaled $3,050. I couldn't find anything to dispute this price until now. Hope you can help.

whenever i brake the truck pulsates and makes a off-and on grinding noise.brakes have been checked many times but was told a couple of times the the rotor hubs need replaced.

MY RADIO POWERER WINDOWS AND INTERIOR LIGHT WILL TURN ON AND OFF AT WILL I WILL BANG DASH SOMETIMES COMING ON THE TRUCK HAD A NEW WIRING HARNESS AND FUSE PANEL BUT SAME PROB BEFORE AND AFTER PLEASE HELP

I have a 2005 F-350. I have a problem that when it was cold it was hard to start. Now it's hard to start at any time. You have to crank on it several times before it starts. Holding the key on gives a code of TBC is at fault. Is that the throttle body control and how much is it and is it a Ford only item. Is it easy to replace.
Ray

ignition switch is stuck in lock position and will not turn how do you check this problem and what are possible solutions

What is the labor hours to replace 8 injectors on a Turbo Diesel

Does anyone know of the location of the low-side service port for the air conditioning?

Thank you ahead of time for your help.

Top

TRASMISSION TENDS TO SKIP THIRD GEAR SOMETIMES , GOES RIGHT TO OVERDRIVE , SOMETIMES EVEN WITH THE OVERDRIVE SHUT OFF ,ALSO SECOND GEAR SEEMS TO SHIFT A LITTLE HARD ,TRUCK HAS 120,000 MILES ON IT , HAVENT CHANGED FLUID LATELY , A COUPLE PEOPLE TELL ME IT NEEDS REBUILT ?

Fuel filters, oil & filter changed 500 miles ago, purchased fuel and put in diesel fuel conditioner 70 miles ago. The fuel conditioner is "Power Service" Diesel Fuel Conditioner, and the 15 gals. of fuel was bio diesel from Shell. About 5 miles ago the truck started fine but after driving it for 4 or 5 miles it began to lose power. Long story short what I found was the truck would start fine when it was cold but after it warmed up it began to lose power until it died. Yesterday I removed, cleaned and reinstalled the EGR valve but it still runs the same. Any ideas?
Thank You,
Joe

Blinkers and brake lights don't work after using flasher.
I can hear the flasher clicking in the back.

Lost power uphill then shut down

2005 superduty f350 4x4. cust complaint is that while driving vehicle lacks power and shakes access for codes, found po299 turbo underboost po470 ebp sensor malfunctio n po500 vss signal malf. b1352 airbag de-activat ion switch warning lamp circuit malf. u1900 can controller data link malf. and u2023 can network malf..........

first thing the battery light come on and off very often than , the cluster gages stop working also the radio every thing is on and off very often, but the engine still work fine every thing is fine except the cluster panel.

It looks as though my rear engine seal is leaking although it looks as though it may be coming from the pan (perhaps running along the seam)

we have checked all connections, all OK. gauges don't register, no schematic in Ford book.

Bought 2000 F350 7.3L in Austin TX. Drove home to MO, no problems. Started it to move so I could shovel snow around it. (Didn't we all have this kind of fun?) Ran for about 20 minutes. Parked it for another 20 minutes, then wouldn't start again. Hasn't since. Mechanic checked codes - none. Sprayed ether into engine. Ran while spraying, then stopped. He suggests changing glow plugs, for about $1,000. Doesn't make sense that they would fail so suddenly. Plugged in block heater overnight - made no difference. Suggestions, please?

First the battery went bad, then the altinator. truck started to stall when you shift from drive to reverse and when you excellerate then release the gas petal. a friend had a simple diagnistic machine and it said the Throttle Position Sensor was bad so we changed that now a neighbor says their is one more sensor that could be the problem but he doesnt know the name it. does anyone have any suggestions to what the problem could be.

My 2008 F-350 has a inline filter,I tihnk it is anyways.Its under the transmission area and is leaking a little.Could someone tell me what that is and where I can get a new one? Thank you Jeff,

The fan speed will not work on the #1 setting

i have heavy black smoke in tailpipe and loss of power

When I am going 45 to 55 a rumble can be heard in front of truck and will end when tranny shifts. Truck will shake for a short distance. Also the check engine light will flicker on then go out

blower will not work,still shows illumination symbols.i will check fuse when blizzard is over.wondering if anyone else has had problems also.went through the defrost blowing full blast when shut off, ford fixed,and servo replaced.now its the blower.any suggestions would help.

I need to start my truck in the morning & I have no idea were the plug is????

it will run good for a few miles ,ill make a full stop at light i try to go and it starts choking and big cloud of black smoke

When i plug in an extension cord to block heater it trips the gfci outlet. any ideas?

TBC fuialer, all the time, Chime, when getting in or out of truck, only when door is open. What can be done.

My crusise control stoped working one day last week. Then my radio only on the sirus radio has the channel and sirus said its working but no sound comes out. now i locked my keys in the truck and the keypad on the door will lock the doors but none of the code work to open the doors even the original key code dosent work something is going on here can you advise if anything you might know about this problem.

This truck has been to the dealership they cant figure out whats causing this noise and its not the pulleys or belts or belt tensioner. When your driving and put the engine under a load it makes a squealing noise almost like a bearing going out. The most skilled people e dealership just said that they dont know whats wrong with it after a day of looking at it and sent me on my way i think their not the most skilled techs out there

how often recommended to change trans oil&filter

i checked the linkage and cable looks o.k , the shift lever has some slop in it .Is the problem in the steering colum?it will start in neutral.