Close

Ford F-150 Questions

Get answers to questions about your Ford F-150 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
2,439
questions

Have 4 new oxy sensors plug wires plugs coil packs fuel filer. Lacks power runs a bit rough and should get better fuel milage (i think) mmechanic only replaced 3 oxy sensors and had 2 in wrong place. Fixed that so oxy sensor test finally complete

Driving 65 MPh truck shuts off no warning , got towed home ,now It struggles to start, when I tap on the gas it dies, If I hold gas it boggs down and smoke pour out the exhaust did have code for bank 1&2 cam senors , cam over retard ?? Now no Codes

Changed plugs and ignition coils and cleaned throttle body. Runs way better but seems to suck gas bad. Owned since new and never this poor mileage

how to change fuel injectors on 2005 F-150 4.6

Maybe drive shaft?

Where is the hose heater core control valve location

no codes? ########

So I got my oil changed was driving to town and pulled up to a stop light and it started to run really rough and the check engine light came on. So I checked the code and it said cam position sensor. So I took it to a ford dealer ship and they said it was a injector so the replaced it. but on the way home it did the same thing running really rough like it was going to die but wouldn't. Then I turned it off and turned back one it did it a little then smoothed out but you could still fell the small miss and the check engine came on. I had a guy come over and he looked at it and said try by changing the oil again and running cfoam through the fuel system and see if that fixes. I just wanted to know what you guys think

Car was running great, put in park, left running, when I went to move forward, nothing, Trans serviced 2 mo ago, fluid and filter, all looked good. If I rev the engine it will move about 2 feet. Any thoughts, suggestions??

I got an engine code 302 and pulled the coil and plug and there is oil all over it

I'm attempting to diagnose a loose steering issue and I'm not finding any play, my wife drives a 97 and while I know they are way different her wheel only turns just over 1.5 times and mine is turning almost 2.5 times. Is this normal or do I have a issue?

Driving push gas it goes then its like your in neutral push gas no acceleration then it goes back to like in drive. Only have 60,000 miles

working can you help me lights was working

Rain leaks and drips into heat duct and runs down on fuse box , this blows the circuit board !

When the temperature outside get 85 or above my truck will suddenly lose power then buck forward while driving. It will rev then buck forward when sitting in traffic. It is not throwing any codes. Fuel pump and filter have been changed.

bought a motor. It had to be removed from wrecked F150 truck.

Had the get replaced wad told to drive it 20 miles. When I took it back was told an additional 50 miles was needed. Took it back wad told still needed to drive it more.

Grinds about every fifth time I try to start it. Used to grind once, now it's doing it 2-3 times. Then starts.

Fuel pump not working properly

Just to changed spark plugs, transmission cooler

where is it located? changed the left, and now I cant find right

need to know if a 197 ford 4.6 came out with a one roll radiator

I have a check engine light that will not clear after replacing O2 sensors due to a P0172/0175 code. The readiness monitors will not reset.

CAN'T FIND WHERE TO CONNECT SCANNER TO CHECK CODES

and engine idles rough

What's the purpose of the EGR my trucks idle is kind of weird I have codes p1401 , p0171, and p0174. Won't go past 45
Mph

The fan motor has high speed only and I have no heat. How do I fix this problem.

No power at selector switch

The vehicle was hard to start this morning. Engine turned over fine just did not fire up right away. once running both the fuel light and oil light stayed on. This truck has the v-6 engine.

I replaced everything from fuse, relay, fan speed switch, resistor, blower motor, still not working, what's next please!!