Ford Explorer Questions

Unanswered Ford Explorer Questions

Ask a Question
View:RecentAnsweredUnanswered
Oil changed 5/19/15 on 5/20/15 after drvin abt 100 miles in town drvin trk dropped pres shut off oil still full there's now a small leak and it will not start bk up. I was told its the oil pres switch?
I took it somehwere and was givin an estimate of $5-6000 and then told it wasnt worht it but i havent had any trouble except for a couple days the engine temp rose not overheated until it did one time hasnt been run s...
But my battery light is still on and my radio doesn't work
Car wont shift into gear when cold. But after warming up it shifts gear normal. Takes about ten minutes of running car before it starts shifting.
Is their a ford trick to solving this issue? Or something else is wrong?
my car is stuck in 4x4 how can i get it out step by step please
how can i get it unstuck
My power passenger seat is not working. I moved it all the way forward to move a t.v and now it won't go back. It clicks when I press the button to move it. it will still go up or down but not front or back. Any advic...
It occurred when I put the seat all the way forward to move a t.v. it clicks when I try to move the seat as if its trying to work
maintanance on front & read differential
The air works fine until there is a load on the engine and then it does not blow hardly at all
Experiencing Rough Idle like the car wants to stall out and sometimes does. Lack of power when accelerating RPM's while Idling fluctuate between 800-1100 rpm . Fixes I have already done include New MAF Sensor, New Ai...
transmission, hard to see but it looks like it plugs into the fire wall or undercarriage? It looked like pure water not coolant.
checked all fuses, fluids. Oil gage reads just above low mark, does not move when engine revs.
I replaced the coil pack this time last year. The codes mean ignition coil B, evaporative emission leak, DPFE SENS circuit (loar voct) and cylinder 5 misfire detected. Does this mean I need to replace the coil pack ag...
In front of the back tire. And it only does it when the car is on. Stops when car is off.just replaced thermostat. I have a picture but can't load it. It is a part underneath the car that has a bunch of holes in it?