Ford Explorer Questions

Answered Ford Explorer Questions

Ask a Question
View:RecentAnsweredUnanswered
This just happened one morning. My battery tested fine but I have no power in the truck and wont crank. Battery charging makes a buzzing sound under dash that changes or stops when I step on brake. I hear a faint i...
The pal here says high 400 range. I know from experience. Labor range actual 4-17 hours? Good journeyman 4-6 hours new journeyman 8-17 this includes labor for all parts. All Parts high cost range 270- 640 low cos...
i just recently purchased this '98 Explorer that has been garage kept,only been driven by an elderly lady & just turned over to the 70,000 mile mark a couple weeks ago. When I first purchased it,I noticed the vehicle ...
its a great truck, Driving lost power pull over and the battery was dead tried getting a jump and it wouldn't take a charge change batteries and now it just crank but it wont start I've checked the starter off check t...
Could you email me a diagram for the cruise control? My email is keziarose01@aol.com Thanks
On the setting knob for Max ac /face/feet/ defrost,I will turn on to max and it comes out of defrost vents at the dashboard. The feet/face setting will blow air by feet but not main face vents. It is blowing cold, ca...
it does not get louder at acceleration it just quiets down to where you cant even hear it rattling,,,any ideas other than the timing chains.
changed motor n tranny mounts iac plugs wires dont it feels like bad mounts woundering timing chain?no codes runs strong
My power steering still makes noise when I turn my wheel. Turning left is louder than the right turn.
We have check plugs, plug wires, altenator, and changed battery. It idles fine in park and when you put it in gear but as soon as you push the gas peddle it boggs and it almost acts as if it is misfireing.
I have to rev the engine so it doesn't die. But it only happens in the morning. Totally fine the rest of the day.
If I attempt again and again it will eventually engage and start. When it does start the battery is strong, the starter is strong and all systems are go. It seems to be some other electronics intermitantly at fault....
one minutee the anti theft wont blink and then it will start then the next minute it will blink for over and hour and wont start. it has a factory alarm, is there anyway to by pass it or and easy way to reset it witho...
Have fuel, have spark, have good compression, all ob2 codes were erased, car will run rill rough then stops running, timing is right, check fuses. what sensor should i check?
I don't have the book for my explore I don't know what fuses are what I think it has something to do with the relay fuse please help thanks