3,192
questions

I have a 1999 Explorer Eddie Bauer. With the A/C on auto and airflow out of the dash vents, airflow will slowly move to the defroster whenever I have to accelerate. Once back in normal cruise, the airflow returns to the dash vents. Does the same thing with heat out of the floor vent. Could this be a vaccum leak at the control valve?

My suv will not shift directly into drive. I can shift into reverse fine and I can shift to 2 or 1 but it takes around a minute or two before it shifts then I can shift it back into drive and it will drive fine. It never slips! What could be wrong.

The transmission won't shift right till it warms up. Put it in 2nd and will shift from 1st to 2nd. Put it in drive and it won't come out of 1st. After the car warms up, it seems to shift fine. Put it in drive or O/drive and it will go through the gears. Fluid level is ok. The trans supposedly was rebuilt in 2000. Some say it might be the solenoids, if so, where are they located? Others say get another trans. Any ideas?

Gas gauge quite working goes all the way down when SUV is turned on goes up when SUV is turned off Please Help

Juat started, took it in, they pulled the counsel and cleaned the seansos and said it was fine. NOpe still gets stuck

Any one have a rough idea on how much a General Module costs to replace?

1996 Ford Explorer Sunroof opened fine, but now will not close. When I push the button to close the sunroof, I hear nothing at all. Looking for the Fuse location for the sunroof. I do not have an owners manual. Thanks

Where can I find the fuse box for the console power outlet?

how ofter is it necessary. My mechanic said it did not pass the test?

this happens most of the time,when moveing from a stop and acceleration. someone has removed the maf sensor and replaced the air filter with a after market filter.
wondering if this could be the prebl
car hesitation or stumble during acceleration

We had this towed from the sellers home, we have tried many things to get it to run. Can you help

instid of my rear wiper blade wiping the rear window correctly, it wipes one time, then it drops down and wipes bottom of door from then on

The shop said the noise my car is making is the wheel bearings. They want to replace the front hub assembly.
The parts store has 2 one is expensive and one is cheaper.
What is the diff. should i buy the best one, and do i have to replace both sides of the front

Please help me or tell me where I should go. What do I need to replace the dipstick it broke in half. Need to remove it and replace it

How much should I expect to pay for a brake fluid flush?

08/18/2010
MY DRIVEWAY. WILL NOT START.

1998 ford explorer

when we folded the rear seat down we can't get it back up. The latch seems to be stripped or broken.

what causes my truck to burn up wheel bearings

1 all around this car runs slightly rough what are some things I can check and or repair to improve this issue(hint I turned it over two years ago )
2 in park this vehicle fluctuates from 900 rpm to 400 or so I want to fix this as I think its getting worse and will just die one day help please.

Only noticed it recently driving to N.Y. A/C had been running for at least 12 hours when it was noticed.

Car shimmies at 65mph.

im leaking power steering fluid but its not coming from the line. it looks like it is coming from where the pitarm is is that possible

My explorer ran fine up until 3 days ago. I was about to turn in my drive way when the car lost all power, kinds bogged down feeling and the belt starting squeeling. I immediately turned in , put it in park and turned of the ignition. Determined the altenator locked up. Replaced altenator. Cranks adn purrs like a kitten but won't move. I have tried everything. Drive, over drive, reverse. Doesn't feel like its going into gear. But then I put it in Drive and gave it all the gas I could adn it tried to move. Kinda like when the emergency brake is on but its not. I checked. I even put it on and released a couple of times to see if it was stuck. I've checked all fluids, vaccumm hoses and everything is fine. We tried putting it in nuetral and getting it rolling then putting into gear and it continued to roll. Any suggestions?

recently, the lighter outlet and stereo stopped working. I do not have a manual. what model fuse (part #) do I need, and where is the fuse location? thank you.

my break pedel go,s right to the floor i pour new fluid in and it leaks back out at the reartire on the drivers side is it a break line problems or something eles.and can i fix this my self.if not what would be the cost of a repair.

while accelerating transmission acted as if it was thrown in neutral (no noises or jerking) RPM's just revved. now no engaugement in any gear. linkage is fine, changed the filter, no metal in pan, fluid level was good, red and no burnt smell. pressure seems to be good fluid level canges on dipstick when engine running and upon removing plug on side of tranny with engine on fluid poured out hole like a water hose at full power.

timing chain, damage to valve bent what else could be damaged?

My car has 50,000 miles. The car will show over heating then will go into safe mode. This my happen for a day the stop. Drove car for 16hr in 95deg. temp no problem. Then happened again today after 10min of driving. Dealer has no clue. Need help

Mi. 66800, I have an engine vibration at idle and below 15mph coming from engine. Vibration goes away when accelerating beyong 15mph. Vehicle purchased new in 2004 and has no engine, transmission demage\failure. Recent repairs include, dealer replacement of rear ABS sensor and reprogram of computer. Another mechanic changed out plugs and wires, compression check done on engine (all cylinders ok), ran through 2 bottles of concentrated fuel injector cleaner. Other than vibration run really well. What could be causing this vibration and what could I expect for a repair bill. Thank you all for your kind attention and assistance.