532
questions

I need someone to tell me why the wrench emblem keeps coming on in my truck

The Wrench light came on in my 2007 ford sports trac. What caused this light to come on ?

I just want to pop it out!!!!!!!!!!!!!!!

How do I get in the access panel in the ceiling?

I have a 2002 sports trac , the body mount bushings are gone. what should it cost to have them replaced? how difficult are they to replace?

won't go into park so i turn off engine, restart and will go only in 4 wheel drive. after i got home i restarted the engine and now every thing is ok.

while i was driving my truck turn off it will turn back on again but it turns off right away check engine light turns on and where the mileage display is it shows check gauges

engine skips, when truck is iodle, when truck is being drive, engine light stays non also bleaks when at low speed, truck level off at high speed engine light still stays on

when driving the rear wheels lock up the brake pads are thin but not dragging theres no noises put on jack stands put in drive the tires start to spin and just lock up no noises to indicate problem the traction control light comes on when this happens

when in 4 wheel drive pulls bad to the right

it does it all the time

All my other lights work. Turn signals, break lights, head lights, interior, ALL work. Just not the rear park lights

I have a 2005 sport trac. Just recently I noticed that when I go up a driveway, I could hear something go "clunk", and the noise was coming from the front passenger side. I finally was able to get under there to investigate the situation and I noticed part of the bushing on the upper control arm is gone and the other one is pretty cracked. My question is can I get the bushings alone or do I have to get the arm which comes with bushings and ball joint? AutoZone tried to sell me the entire control arm but I really don't need all of it. My ball joints are fine.

My check engine light was lit up so I hooked up an obdII and cleared it after repairing problem. Now when I went to smog my truck I found out that it won't pass until I complete a drive cycle. So far everything has checked out good except for the EVAP system section which still says incomplete. I drove my truck like the mechanic said: 30 min. at 65mph but it still says incomplete. What else can I do to make it complete this test?

My 04 sport trac is losing coolant sometimes. Today I went to autozone to get a new radiator cap. I parked uphill(30+ degrees) and when I shut it off I got steam. Looking under the truck and under the hood I had dripping from the bell housing area? put more coolant in reservoir and drove 1 block to store. No steam or fluid. drove the ten minutes back home and still nothing? I know I losing fluid somewhere. I check it everyday and sometimes it's 1/4 of an inch low and sometimes I check and it's empty? I'm a good shade tree mechanic. I've worked in shops and repaired my own for years! I'm lost this time! HELP!

My sport trac will start if it sits overnight. I start it up it the morning and runs fine. If I drive to a few other locations, after the last location it will not start. It tries to turn over, but will not. I have to let it sit for a while, at which it will start.