Ford Expedition Questions

Answered Ford Expedition Questions

Ask a Question
View:RecentAnsweredUnanswered
Their machine and it printed out a code p0401. What does that mean and what i need an eestimate of what the repairs might cost. Also wondering if there are any recalls for this make and model 2001 ford expedition eddi...
I took the 4.6 out of my expedition and put a 4.6 out of a mercury cougar and it will turn over but will not run
My check charging system is on, I've went to auto zone had them check i was told the battery was at 84%, and my alternator was great. About two months ago the alternator was replaced. Also when I press on the breaks t...
I heard rattling from the engine and thought it was the a/c compressor. I kept driving and check engine light came on. I checked battery, alternator, water pump, and power steering pump. They were all good. Then anoth...
Didn't pass the inspection, the reason "NOT READY" they told me that I need to perform a drive cycle. The gas pump isn't working promply, doesn't mark the gas level on the dashboard. It could be this the reason for th...
I already checked the inside fuses. All other lights work just not the break lights.
Yesterday leaving my house started the truck put in drive and when I pushed the gas it drove but rpm was high and it was not catching speed. Checked transmission fluid. Was low so added fluid. Tried to drive again did...
antifreeze leaking from rear end of truck
My transmission went out and they replaced the "brains". Now I'm told it may take 1000 miles to "learn " how to work correctly.
I replaced my brakes christmas day then feb. 7 2015 i replaced brakes calipers and rotors 3 weeks later brake fluid was leaking i went back and was told a washer came lose it is now 7 weeks and my brakes are scrubbing
So, when my car warms up after driving a while it starts to sutter every time I hit the gas peddle.
Battery went died got it charge up and my radio and DVD player stop
truck shuts off truck sHuts off while in reverse and when driving forward and the brake is applied. But if the truck is parked it won't shut off... please help
slipping and grabing,during this sensation there is a increase in the R.P.M. and also the check engine light comes on
check engine light on, code P0305 changed spark plugs, ignition coil, and upper and lower gaskets. The engine shakes, especially when vehicle is first started, and smell coming from exhaust. mileage 135,598
the ticking noise is intermittent and does not happen constantly, but the idle seems louder than regular.
the scanner shows me the U0100 Code: there is lost whit ECM/PCM. And everything I tried did not start the car.
Cranks and idles fine.when you drive it starts hesitating and acting like it wants to go dead.
I just replaced my mass air flow sensor and two oxygen sensors but I ran the car for a month with a.defective air flow sensor too whats my problem can anyone help