160
questions

How much should it cost to replace a fuel filter, air intake heater relay, and exhaust backpressure sensor on a 2000 Ford 4WD Excursion with 7.3 litre Powerstroke diesel turbo? This was determined by diagnostics run at a shop after the "check engine" light came on and my wife brought the car into the shop. The vehicle was running fine with no symptoms, other than the illuminated "check engine" light.

Can not locate EGR , no tube running from exhaust manifold and no DFPE on throttle body. Have a rough idle and rough acceleration but runs smooth until it hits lower RPM

Both lights came on this past weekend, by the time we arrived at home- BOTH units now pull heavy to the right at slow speed and you can feel the brake pedals pulsate. I am stumped because both units the same day with the same issue??????

when i took my car out this morning i had no turn signals ,hazard or brake lights , i checked the fuse it was blown , tried to change it but it keeps blowing.

They will totally lock up and I have to pump them before they will release.

Transmission will often not shift out of park. This happens in my 03 and 05 Excursions. I try depressing the brake pedal numerous time. Simetimes this works but most often not and I have to turn the ignition switch half-off and shift to neutral, restart and then shift to reverse or drive. The Ford dealerships I've taken it to can't explain it and only say it could be in the brake lights.... Just curious if anyone else has experienced this problem?

I CANNOT DRIVE MY TRUCK FOR 10 MINUTES WITHOUT THE ENGINE OVERHEATING WITH OIL SPILLING OUT THE RESEVOIR TANK NEXT TO THE RADIATOR, EVEN BUSTING THE CAP OFF BECAUSE OF THE PRESSURE.

Had to replace om engine on my truck with rebuilt engine from Road Master.my shops labor rate is $95/hr. Shop said labor costs are $3300.(I supplied motor & install kit ($3180 & $380 respectively)

also if I put it in reverse it dies any body know what it could be

I can't get it to hold the spark plug in

my car ran good for an hour then started to die every few min. it started back up after set for a few min.

just replaced fuel pump and filter

just replaced fuel pump and filter

replaced and still does it.

had auto zone check it out- mumbled something about memory or nodes?

Truck is garaged so it is not subjected to extreme cold. Starts right up after glow plug lite goes off but has low power for approximately first five minutes and then runs fine. If outside temp is 60+ no issues with power. Air filter, oil and oil filter replaced with no significant difference.

2001 ford excursion diesel. If you know about this problem could you tell me how to fix it. Thanks

it acts like its not getting fuel,it takes 10 or more trys to get it to start.

The fuel filter has been changed and so has the fuel pump, and it refuses to start again. The engine died as I was getting ready to get back in after starting it up to go home from work and it acted like it had just ran out of gas, no surging, missing or coughing, just slowly losing RPM's and died.

Nothing smells under the hood and no obvious animal carcasses on the chasis

When I turn on the air conditioning, the rear ac blows ice cold but the front vents only blows warm air like just the vent is on. Fuse# 27 & 110 is good.I put a new vacuum pump and front blend door and heater valve. No luck.

I was told to spray wd 40 in driver door latch would normally fix the problem but it didn't (for the lights).

i replaced pvc valve beacuse truck was hesitating a little took away 90% of problem hit on the free way into over drive starts a little sputtering kind of like jerking i was perfect on drive & while im driving

the tip of the ignition lock cylinder is still in the steering column. do i just drill it out?

How do I replace the ABS Brake sensors in the Excursion. Is the a sensor located in the differential ?

I changed out the corroded battery cable on my 2002 Ford Excursion 7.3L Diesel. The positive cable that goes from the starter to both batteries. Once I hooked it up the interior lights and the running board lights turned on and now they wont turn off. I tried unhooking both negative cables for a few minutes to reset it but that didn't work. Any other suggestions? Thanks.