Ford Escape Questions

Answered Ford Escape Questions

Ask a Question
View:RecentAnsweredUnanswered
Im trying to replace temp sensor located between cyl #2 & #3 in the top of head.A standard 19mm deep well does not fit,it won't get by the plastic electrical connector.... Any ideas, I've tried all auto parts stores, ...
this happened when a new transmission was put in like the car was not backed up, took to the dealer and they did something and the radio was clear.
Pass couple weeks, the throttle playe area was cleaned wasn't crack& installed new air filter. Then the car felt like it has a misfiring with a soft popping noise in the throttle body area. The check engine light bega...
I have replaced sensors on transmission and the driver's back wheel. Still no luck.
At the last oil change 3 weeks ago, the washer fluid was topped off. I was told the fluid they use is for -20 degrees.
WHEN i TRY TO START CAR THE ALARM GOES OFF AND CAR DOES NOT START. IT STARTS IF i JUMP IT OR SOMETIMES IF i USE KEY TO LOCK AND UNLOCK A FEW TIMES IT WILL START. iS IT THE BATTERY, THE ALTERNATOR OR A SHORT IN THE E...
My throttle hung wide open was able to get it. In neutral n the e brake on was wondering if it would be covered under the recall
Air flow will not change from defrost to vents to floor. Only blows through vents
Tried all the opening codes from manuel
Gauges rapidly go back & forth few times then miss goes away & gauges return to normal.does this in park, neutral & drive.
It will only get warm not hot when driving. If I turn it on high it blows cool air. What could this be? It very cold and I freeze when in my car
I was told my air conditioning unit is plugged because accumulator breaking down. I was also told they need to replace all major AC components to repair. Is this true?Thought they could be cleaned out?
I changed the egr yesterday and last night went to driving and the egr valve blew a quarter sized hole right out the side of it .
Just had catalytic converter replaced, new flex hose, new spark plugs, tune up,and 02 sensors replaced. Service emission light came on again. Prior to replacing of parts engine was hesitating and did not run smooth-it...
It sounds awful and my code came back as a bad cat on Bank 2. I have a bolt on direct fit replacement cat and I am no pro but i know my way around an engine. Any advice or tips would be appreciated too.
Mechanic says I need a new engine. 95000 miles. Oil too low and dark- tried oil change. ..no help. $6000.00 to replace engine. Seems high..should I go ahead or change cars?
The fan just quit working on lower speeds all at once. No warning. No working sometimes and sometimes not.