219
questions

When I try to accelerate, it accelerates very slow and sometimes there is a shaking that occurs at around 50mph but goes away once it goes faster, it won't go above 65, is there anything I can to do to stop the shaking and give it enough power to travel highway speeds

My truck starts shaking once in awhile I lose power my engine light comes on. In order to stop it I have to stop and turn off my truck and turn it back on and continue on. It comes and goes

Hi, I have an error code “B0001” on a 1996 Ford E-250 Econoline, 4.9L engine. How do I resolve this? Thank you!

How do I fix error code C1211. My make and model is the 1996 Ford Econoline E-250, 4.9L engine.

I go to turn the motor on i hear this loud knocking noise which wasnt there before now im afraid it could be the timing chain or a rod bearing i had someone look at it and they said it was the cat. Converters that were bad and needed to be changed i dont agree with that theory the noise sounds to loud for that to be right. This problem happens now everytime i turn it on its so loud that i dont run the engine now.its a constant thing. Any answers to my problem hopefully i can fix it without replacing the engine

my red check battery light is on and sum times flickering took out alternator and had it tested and it was ok 13.8 volts , I put it back in and the light was not on turned the van off and restarted it and the light came back on. any takers on this problem thks dave

This is is my 2003 E250 Ford Econoline Van. It will not go into gear ever since I reinstalled the transmission in it.

orileys gave code

the side door on left wont open

If it were a carbureted car, I would say it was poor acceleration enrichment. The engine operates normally at high speed cruise, although the acceleration is sluggish in reaching cruise. After a long traffic light idle, the idle collapses, the engine idles erratically and sometimes stalls. It willl start and run normally after a stall. I have replaced the out of spec coil pack, the TPS, spark plugs and faulty ignition wires. Although there is no code for it, I am thinking of replacing the CPS. Any suggestions?

Front calipers and rear wheel brake cylinders have been replaced: no change. If pedal is pressed very lightly and "idiot lights" don't come on, problem is greatly lessened. When pressed hard enough to light up anti-lock brake and brake idiot lights on dash, problem is more aggressive, the harder you push the pedal, the worse the problem. When left to sit for 1 hour, goes back to normal. Van has 17,000 miles, was a police surveillance vehicle, was very well maintained, saw very few miles, is in otherwise as new condition

I'm having high engine oil consumption but I don't have any leaks at all ?

I have checked the following, shift cable, shift cable connections, shift cylinder on the steering column, replaced brake light switch and neutral safety switch and not solved the problem yet.

Changed fuel filter. It runs great as long as foot on gas.

Feathering gas helps but dies at low rpm

Will it work if I drop the transfer case on the tranny with the 4x4 ?

I replaced Starter and battery. Sometimes it cranks and now no crank or any connection