Close

Ford E-150 Questions

Get answers to questions about your Ford E-150 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
410
questions

I was driving my van on the interstate and it made a noise like the power steering needed fluid and then it just shut off had to be towed I got it home and put it on the tester and it read 4 different codes for the TPS was high voltage and same for the eve Will these make it not run?

Can someone please tell me why my van stopped running and will not start back? What happened is I was driving down interstate and van started making a loud winding noise like the power steering needed fluid and then it died had to be towed! I put it on the tester and it read 4 different codes that had to do with the throttle position sensor said it is got a high voltage reading and the other about the egr valve had high reading also could one of these or both be my problem from getting van to start?

Will a bad throttle position sensor or a bad egr valve cause my van to stop running and not start back?

Would a bad throttle position sensor or a bad egr valve cause my van to stop running while driving down the interstate and not start back! It just turns over won't start?

I was driving my econoline 150 down the freeway and it started making a noise like the power steering needed fluid, a loud winding noise, and then it stut off want start back I plugged into outer and codes I got stated the throttle position sensor had high voltage or something and the egr valve had high or low voltage can these things keep it from starting?

I was driving my van it started making a noise like the power steering needed fluid and then it just quite running and want start back what could it be it turns over but want start it read codes like the throttle position sensor had to much voltage and another code said the EGR valve didn't have the rite voltage or something would either of these keep it from running

It looks like a vacuum can aster

have a 1991 ford e 150 econoline have duel thank the gas is sic-fume gsa from one thank to the other backward and forward how to fix this problem

This happens all the time

Completely died WHILE driving. Will crank but not start. Thougt it was the fuel pump & tried starter fluid but did not work. Read that there could be numerous issues & hopeing u can help me narrow them down. Im a single mom & dont have a lot of $ to just be throwin around. Thank u.

Had close to a quarter tank of gas in it and I add like4or5 gallons of fresh gas.

I would like a diagram or a good description of getting to both ends they snapped while removing the housing to the altenater I can almost see the end close to the top under hood on passenger side

Check engine has been on for long time but barely use van. Recently it feels like van is like misfiring, losing thrust and check engine light started to flash on & off. Please help...

Heater not working on my 1997 E150 Econoline Ford Van

I need an experts response cause it's been tinkered with several time's with no luck @ being fixed. No

The engine stumbles maybe every 50 miles. I have replaced plugs, wires and a fuel pump, it has about 90,000 miles on it. I had a shop put in a remote alarm system for me about three years ago, they must have disconnected where you read the codes (it does not work). Any help would be useful.

Trying to find our where the location of the motor mounts are on my ford e150 ecnolive van

Play in it can I use motor oil in rearend til I can get rear end oil

It happens between 20-35 mph. It slips out of drive, sometimes, if I mess with the column shifter it goes back into drive. If I stop at a red light, the tranny goes back into drive.

My repairman has indicated that the steel brake line is no longer manufactured nor can it be found anywhere. This seems crazy to me. Are there workarounds? Is there something else that would work? Our van has been out of commission for 2 months waiting for this repair - front brake line broke.

I changed brakes bearings (upper&lower)rotors and car is worse now... p.s. there was only front side of brake pad on passenger side tire when I initially took in for work... i got van checked 4 different times each mechanical agreed it was bearing but so not true it's been changed 4 times now can someone please help