395
questions

I would like a diagram or a good description of getting to both ends they snapped while removing the housing to the altenater I can almost see the end close to the top under hood on passenger side

Check engine has been on for long time but barely use van. Recently it feels like van is like misfiring, losing thrust and check engine light started to flash on & off. Please help...

Heater not working on my 1997 E150 Econoline Ford Van

I need an experts response cause it's been tinkered with several time's with no luck @ being fixed. No

The engine stumbles maybe every 50 miles. I have replaced plugs, wires and a fuel pump, it has about 90,000 miles on it. I had a shop put in a remote alarm system for me about three years ago, they must have disconnected where you read the codes (it does not work). Any help would be useful.

Trying to find our where the location of the motor mounts are on my ford e150 ecnolive van

Play in it can I use motor oil in rearend til I can get rear end oil

It happens between 20-35 mph. It slips out of drive, sometimes, if I mess with the column shifter it goes back into drive. If I stop at a red light, the tranny goes back into drive.

My repairman has indicated that the steel brake line is no longer manufactured nor can it be found anywhere. This seems crazy to me. Are there workarounds? Is there something else that would work? Our van has been out of commission for 2 months waiting for this repair - front brake line broke.

I changed brakes bearings (upper&lower)rotors and car is worse now... p.s. there was only front side of brake pad on passenger side tire when I initially took in for work... i got van checked 4 different times each mechanical agreed it was bearing but so not true it's been changed 4 times now can someone please help

started when engine cool but after running and hot it would not start. Now even with engine cool will not start, can smell gas and pumps are working.

I have changed pretty much everything. ICM, distributer, delco, and more. i dont know what else to do. I will occasionally get a spark . I need help please.

When the van gets hot it loses acceleration and let the pedal off and gained acceleration and also misfires

the truck is not driven every day, some time sits for week or longer.

the battery light is on the dash, the alternator indicates that it is charging but will not run with the disconnected.

I changed the Instrument panel volt. reg. Problem still exists. I did notice input to cooling temp gauge has ground wire exiting that has been spliced and connected to steering column bracket.

Up hills seems to come on more prevelently, can I do this fix myself, new ford owner.

The air will blow out on the windshield for the defroster. Are there vacuum lines which control this?

Replaced the fuel pump in the front tank. replaced the ECM computer. Pulled the code 542 and the tank switch is reading fine. Truck still isn't getting fuel