Close

Ford Questions

Get answers to questions about your Ford at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
26,736
questions

no miss fires while monitoring. plugs are new plugs showed sign of excessive fuel.

Also what are the size of the pipes that the catalytic converter connects to.

88 degree day. Full tank of gas. Kinda sputtered twice during restart attempts. Could it be the brain box CPU thing or is it fuel filters or pump? The vehicle has run incredibly well ever since I bought it in 2002. I am the only owner and van has had regular maintenance ongoing every 3 to 5 thousand miles. Triton V-10 Engine, 15 passenger Van with towing package.

I had a head job done about 3 years ago. A few months back truck started running bad would barely go almost as if cat. Converter was stopped up. Codes po300 po301 po303 po305 came up. So i took those 3 spark plugs out. They had alot of carbon build up on them so i cleaned them like new put back in codes went off. I drove for a month no problems then same thing again. So i cleaned put back in it ran worse than ever so i changed coil pack still the same. I carried to a mechanic. He is tryn to tell me it has blown head gasket again but it doesnt run hot or use water and oil or water wasnt on plugs neither was any fuel. I feel like he is trying to fuck me over. I know that only reason these codes should come up is because #1 to much or not enough air #2 not enuff fire #3 not enough or to much fuel.. has anyone had this problem with your 07 sport trac 4.0L? And how did you get it fixed? Ive had nothing but problem with this piece of shit ill never buy another ford their junk!!

It is in anti-theft mode, and when I put it in the ignition, the anti-theft light blinks, and the vehicle won't start.

location OF THE FUEL FILTER

Catalyst evaporative system. What do I do .

The Mustang is leaking from the back into where the radio system is so I had to get my amplifier fixed but there is a leak in the hood towards the back.

Would like to have a rebuilt engine put in my vehicle.

Need.To know what has to be removed to replace power steering pump on 2005 Ford five hundred

it stops when i accelarate but continues again when i let off the gas. i put air in all tires and it still knocking/thumping. what could it be?

load..try and start the truck again and it starts and runs fine until you start back down the street...go a little ways and there it does it again... now i have checked the fuel pump and cleaned the gas tank, put new soark plugs and distributer and rotor but getting same results..also tryed to clean the intake the best i could with throttel body cleaner...

charged system up

Help
My truck is only going backwards

ses light is on and I changed MAF sensor about a year ago

friend said engine was replaced, need to see what year the eng. is. States runs well until warmed up. check eng lite is on.

And for how long?

Nothing happens when it goes from Neutral to Drive or Reverse. It is like it does not engage. It has a dip stick. Where is the fill cap located?

The tensioner has been installed. Where can I get a video showing how to install the serpentine belt.

this is an on and off issue sometimes they work fine. tried both fobs with new batteries in each and issue continues

Why is my Power steering leaking at the pressure control valve and don't know why

this can occur while driving I have not had it happen right after driving and it just started

Or it's leaking for the seal are

WHEN DRIVING THE TACOMETER KEEPS BOUNCING BETWEEN 2 AND 1. IS THIS A TRANSMISSION PROBLEM i ALSO GET A LIGHT WITH A WRENCH FOR TRANS. PROBLEM

I need to replace the water pump and I want yo know its location.

new struts and bushings have been installed but still very load banging comeing from front

Nothing was left on. Just bought car Friday. Technician came to house and had to jump start it. Drove back to dealership. Also noticed radio wasnt working. System check shows battery above minimum level. Everything checks out ok. Total system reset and radio still not working. My check hasn't even cleared the bank yet.

It's getting fire with switch on to coil about 12.25 volts still no sparks with brand new distributor and coil wore and spark plugs?

Can't figure out which fuse works sofa was working let daughter use it now it's no working any help would be appreciated thz

This problem didn't exist until I replaced the timing chain, when it feels like I hit the brake the engine continues to run fine