Dodge W150 Questions

All Dodge W150 Questions

Ask a Question
I've checked tons of auto part sites and can't find one anywhere in town, the auto stores don't carry them, and the few trucks I found in the scrap yards around town either didn't have a fuel tank anymore, or the the ...
The truck run when first started, will idle for about 30 seconds and then dies. I have my Genisys hooked up and the coolant temp and air charge temp will go from normal to -198 degrees, the battery voltage will drop t...
The truck will run for a little while then stall out. with my genisys hooked up I can watch the data stream and the battery volt will drop to 0, the RPMs drop to 0 the air intake temp and coolant temp bounce from norm...
it has always been very dependable util last week
Slave cylinder is a Lockheed, the master is missing so I don't have much to go on. The mounting bolts are 3/8" diameter on a 3" center mounted in the horizontel position. It uses a Dodge slant 6 engine with 4 speed ma...
buying a 1992 dodge w 150 test drove it and noticed that the and brakes were a little loose and also transmission was slow shifting there asking $1200 for it. The motors strong and the body was well maintained. is thi...
transmission leaks around seal was told that this is the reason it shifts slowly. just wanted to know if that could be true before i invest in another transmission
No start under 15 degrees. I seem to remember map problem reading temp to high & leaning fuel too much to start ??
map sensor going out need to know where it is located
both my headlights stopped working at the same time. i found this to be wierd. the hi-beams would work, but i had to hold the lever for it the entire time. all other lights work. i replaced headlamps and still having ...
My 92 Ram has stopped shifting into overdrive and at the same time my speedometer and cruise control quit working. I'm thinking it is an electrical problem, because everything worked just fine before. I have checked t...
1987 Dodge ram 150 or 1500 pick up truck. I've put 2 new alternators in & neither one is showing voltage or what ever & isn't charging battery & my mechanics & I can't figure out why. please help?
we have pulled the hub and and cant get the bearing out of there is there a special tool or does it just need more force? It is a four wheel drive, once i removed the hub and the peice behind it there is 2 1/4" diamet...
please advise component location of fuel pump relay
My left tail light doesn't work but when i hit my brake the light works. I changed the bulb and checked the fuses. I'm thinking its a wiring problem but not sure.