8
questions

My care is showing 15psi at idle and I was just wondering if this is normal for this car?

Ac will work when you turn the temp knob all the way down to the blue dot. Thanks John

My 2009 Challenger SRT 8's battery was dead. And I trickle charged the battery back up and started my car. And the esp light is on, and when driving the car and I brake the car starts jerking around (more like a vibrate). I tried the turning the wheel to the left and then to the right and it did not work. That was with the engine running. The car ran fine and drove fine before the battery died. Can anyone tell me anymore tricks?

Also, I have never hit any curbs or anything to jerk the wires in the wheel area.

My engine is a 6.1 Hemi without a drag pack. Everything is stock on the car.
I have tried reading the manual and I cannot find the section on what to do when the battery has died and what problems I may have when the battery had died.

The battery died because I stored it over the winter months. This car is so complicated with all the electronics on it.

Thanks!

~Jennifer~

My 2009 Challenger SRT 8's battery was dead. And I trickle charged the battery back up and started my car. And the esp light is on, and when driving the car and I brake the car starts jerking around (more like a vibrate). I tried the turning the wheel to the left and then to the right and it did not work. That was with the engine running. The car ran fine and drove fine before the battery died. Can anyone tell me anymore tricks?

Also, I have never hit any curbs or anything to jerk the wires in the wheel area.

My engine is a 6.1 Hemi without a drag pack. Everything is stock on the car.
I have tried reading the manual and I cannot find the section on what to do when the battery has died and what problems I may have when the battery had died.

The battery died because I stored it over the winter months. This car is so complicated with all the electronics on it.

Thanks!

~Jennifer~

It clucks a little but then it screeches only when turning a sharp right no other noise

what could be wrong the lights doors radio trunk and everything else that is electrical is working but car just makes a clicking noise up front by the integrated power module

everything comes on and a lightning bolt comes up