Chrysler Town & Country Questions

Unanswered Chrysler Town & Country Questions

Ask a Question
View:RecentAnsweredUnanswered
It like in the old days when you was trying to get a veh in time.You bump the key.
When I open the tail gate with the remote key, sometimes it will come back down.
Rear sliding door locks will not work with key fob or button on mirror. Will only lock or unlock manually. Once unlocked, the doors will open with remote.
checked belts alternator. Could it be the idler pulley? Only makes noise when rpm is below 1200 rpm. Any suggetions?
key off stays on till battery dead
This week computer numbers have continually dropped even after being reset and driving normally. Normal hi-way mileage is 28-31mpg; now is only 10-11 mpg, yet fuel consumption on hi-way is still healthy. Vehicle is ...
I installed a new JVC stereo using a wiring harness. The power comes on, the CD plays, but there is no sound. If I uncouple the harness and then plug in the OEM stereo and let it turn on and play that CD you can hear ...
Heater takes a very long time to heat the temp gauge stays in the middle never over heat. Drive for 20 min heat starts to work somewhat have it all the way up but only comes out Luke warm then it stops blowing warm ai...
This happens every time I start off from a stop it jumps like three times then ok.
We had a tune up,a radiator hose replace, and the third injection replace within the last two months. It can not pass the e check, keeps reading not ready. What is the next step to get this van to pass and the check e...
I have lost a little stuffed animal behind the panel of the back of the lower glove compartment. I cannot find a way to get the glove compartment out. The compartment will still close, but it is hard. I really want th...
what would cause the transmission not shifting into reverse?
I recently replaced my power steering pump and it has been steering fine, not losing any fluid. But almost a week to the day later and it is making noise, and now the steering got stiff again, and the batt light came ...
engine warms up to normal operating temp not overheating. Just blowing cold when stopped then as u start to accelerate warm air blows out
I'm getting code P0700 and code p0720. I was told its the output speed sensor and I need to know where this is located on my van