1,816
questions

It will start and run good for a couple of days and then just stop cranking the engine over I've replaced the starter and still having the same problem

Happened all at once to both side doors.

Full on coolant? Heater inside never gets warm @ all?? Radiator has card board in front so no air can get through and still very cold. All hoses are cold!
Thanks

Oil leak has been going on for a while Even after having a new pan and gasket put on it still drips constantly. New issue just started, vehicle shudders at low speed. I allowed the vehicle to warm up for 20 minutes prior to jumping in, then was startled by a quick paced shudder almost similar to that of a flat tire feeling but as if it were coming from the engine. This only seemed to happened when initially giving it gas. I drove it around the block to see if it passed, it continued but at a lessor degree o once above 40. Then as I sat with it running in park I noticed little power surges. The rpm gage would jump just a little and the lights on the dash would dimmer. Now what could this be? Please don't say transmission.

how do I reset anti theft system, changed battery terminal and now will not start, it just clicks, and remote start will just turn on running lights one second and nothing.

thermostate has been changed, radetor cap has been changed,

Ignition switch replaced in 2015. Nothing electrical will work, not even with a new battery.

Loosing antifreeze spraying all over motor does not overheat tried stop leak

My doors stay on the frix now all of my interior monitors just quit at once.

Car starts. Wipers and headlights won't turn off. Dash lights flicker. Red light dot is on dash above steering column even when car is off. Message center is blank. Van worked normal yesterday. Cold outside, -10ish, but kept in 50 degrees all night so cold shouldn't be a factor.

No heat on my feet.

Need to recalibrate the control? Also small ball bearing goes where on heater control knob? Heater works fine but is stuck on defrost only.

on is there a computer problem?

Where is shift solenoid? Can I replace it at home. Speed sensor replacement did nothing.

my abs light wont turn off

I came home from work parked it came back out to go to the store and no start

the where is the inside fuse to my Chrysler TownCountry cuz I can't find it

The passenger side door got kicked off the top rail. How do I get it back on myself?

Help! Actuators move when temp number is changed on either side. All modes blow air as designed, all fan speeds work. Heater core is clean as a whistle, hoses hot going in, slightly cooler going out. Radiator full. Restrictor valve clean. Removed actuators and operated doors by hand and I feel them going from stop to stop. I have found four actuators in this van, three on the drivers side (top one mode, front lower passenger, rear lower drivers) one on the passenger side under the blower casing (recirculation?). Still no heat, is there another? Sometimes (rarely) it will blow hot and then cool down and not get hot again. What am I missing? What else can I do to diagnose this problem, its driving me nuts!

Two injectors are misfiring, after I changed the timing belt, the car can only drive at 30mph. How can I reset the injectors, or have I made a mistake somewhere. I can hear that the engine is perfectly timed, but two injectors are shaking. 2.8 crd, 2009. Any advice appreciated.

all the time

Just replaced the er value did not stop the problem have replaced plugs and coil packs has no codes anywhere

Appears to be coming from fuel filter.

this sometimes occures and sometimes it doesn't but it is happening more frequently.

side and also the van makes a low wooping noise

noise when ever I drive it

Don't know when signals lights stopped working. This is the first time it happened. I got the van new.

We cannot turn on our interior (reading) lights on idividually. They turn on when the doors are opened or if the dimmer dial is all the way up so we know the lights themselves work. But NONE of them will turn on individually. It does not matter if they're pushed in or out, they won't turn on. Is there a master switch or fuse that we're not aware of? We've had a couple mechanics look at it, including our local Chrysler dealer, and they have no idea.

After being stopped at a light, when the gas pedal is pressed to move, the van jumps. Then, it will absolutely NOT shift. Driving down the freeway at 40 mph and 3500-4000 RPM is not my idea of a good time. The last time this happened, beating the shifter side to side seemed to fix the problem as if it was stuck in third gear? Ideas?

I believe this may be a common problem for 2008-2010 dodge caravan/chrysler town and country. Rear wiper arm becomes loose on wiper motor shaft.

cel on - code po456- I have the pump
just want to know where it is go I can replace it.