Chevrolet Venture Questions

Answered Chevrolet Venture Questions

Ask a Question
View:RecentAnsweredUnanswered
I have replaced all the hoses and thermostat and the van still over heat
changed valve cover gasket, putting it back together there is a hose that comes off the ribbed piece near top right of the engine where does the vacuum hose go?
tension pulley replaced already, all other bearing seem okay
Just stop working! Speedometer TECH FUEL & TEMP RADIO reads LOCKED
The one I'm looking at has 200000+ and I want to get an idea of how many more I might be able to get out of it.
It over heats and I can smell it I was told it might be anti frezze a hose or temperture gage.
I did a carmd and it showed me the areas to get check out the H02S-11 heater circuit malfunction (Bank 1 Sensor 1)
makes the noise as you drive. no change in turning acelleration..checked CV joint.
I am having Chervolet Venture, model 2004. Recently had failure in engine belt and had replaced with new (alongwith the tensioner). After replacing the engine belt (probably after 1 week), it is observed the engine ov...
I changed the heat sensor now the temperature hand moves from cold to hot I had the radiator reworked ,i flushed out the heater core and I changed the thermostat please tell me what's wrong
Even when I disconnect the battery a high pitched, fast, chirping noise comes from what sounds like the inside back of the van.
How much would it cost to replace both wheel bearing hub on fwd Chevrolet venture van
I've replaced the fuel-pump,fuel-filter,alterntior,cam-sensor,map-sensor,crank-sensor and battery. It runs a little better, but it still turns off. And eng.light is not on?
My ABS engages all of the time. i replaced the speed sensors and it stopped for about 2 days and then started back up. What else could it be?
I replaced the fuel pump,fuel filter,cam sensor,crank sensor and the fuel tank. And it is still running rough. I turn on my van go two or three miles down the road.It starts losing power, back firing,poping sounds and...
It acts like it wants to crank but wont