1,703
questions

The driver door is out of adjustment. I have replaced the door pins and it didn't help.

It takes up to 30 mins to start after shutting it off and about every 10th time the clock resets or I get an err message on the radio. Also the push button 4x4 does not work at random times. I am wondering if this is all one electrical issue. Has a new fuel pump and a new battery.

recently after getting into my truck the door chime began to ring as I was driving and now it rings constantly while I am driving but will stop when I stop at a traffic light and begin again as I proceed to drive. it is driving me crazy!

driving more then 25 mi check engine come on "engine hot a/c turn off" the motor fine coolant is full no sign of a hot so I remove ground from battery and wait 3-4 min put wire on and the light out until next time

How much oil will come out when I unscrew oil level sensor to replace on 07 Silverado

Just did oil chanage

issue to worry with. This only happens about every 4-6 months.

Control panel lights up and temp. shows up. Blower speeds adj. on control panel but no blowe speeds.

6 months ago it did it to me and found that starter was bad replaced it and now 6 months it did it again and there is no power to starter replaced neutral saftey switch still nothing still do not voltage at the starter when trying to start.. does anybody knows what i need to do from here thanks.....

AFTER CLEANING THROTTLE BODY,MY MIL LIGHT TURNED OFF,BUT,NOW I'M GETTING CODE PO507,WITH MIL LIGHT OFF,THROTTLE BODY WAS VERY DIRTY,I HAVE A OBD11 SCAN TOOL,CAN I RESET ECM TO LEARN THROTTLE,NOW THAT IT'S CLEAN,I WAS TOLD WHEN THROTTLE IS DIRTY ECM MAKES ADJUSTMENTS TO IDLE,SO NOW THAT IT'S CLEAN ECM HAS TO RESET,THAT'S MY UNDERSTANDING,NOT COMPLETELY SURE,ANY ADVISE APPRECIATED AS USUAL,THANK YOU

STARTS UP A LITTLE ROUGH FOR FIRST COUPLE MINUTES,HAD MIL LIGHT ON LAST WEEK,WITH CODE PO137,NOW IT'S OFF, BUT GETTING CODE PO507 ONLY,WITH MIL LIGHT OFF,ANY SUGGESTION AS ALWAYS APPRECIATED,,,,,

Just realized my oil pressure @ idle, is only 20.driving it'll go to 40., is that bad, should I worry, what is cause of it, I'm presently getting code PO137 only, it has a rough start, but after three minutes sounds good, any suggestions appreciated as always,

My truck had a rough start to it 2 months ago and I could smell fuel. I took it to Chevy dealership to run diagnostics and found codes P01072 & P01075 stored in the ECM and alcohol content at 74%. They reprogrammed the ECM and reset the alcohol content and it corrected the starting issue, but they said if light came back on it was likely due to fouled spark plug/wires. I drove around 40miles to my office and parked, got back in an hour later and the check engine light was on again. Stayed on for a day or so and went off. It did not come back on again until today after I left the same dealer ship from getting oil changed & tire rotation. I know what the codes are for and the several issues that can cause them, but wanted to check to see if anyone had similar issues and what they had to due to correct it? I would prefer not to spend a lot of money for them to troubleshoot by changing parts. Thanks

help changing my heater core

ENGINE LIGHT SUDDENLY CAME ON,SCAN OBDII,GAVE ME PO137, FREEZE FRAME- THROTTLE POSITION-21.1% , ENGINE RPM- 1622 RPM, LOAD VALUE-14.5%, AIR FLOW RATE- 33.21 GR/SEC, MAP SENSOR- 84 KPA, COOLANT TEMP.- 190 F, LONG TERM FUEL TRIM -15.6%, SHORT TERM FUELTRIM 2- -2.2%, LONGTERM FUELTRIM2-- 11.7%, SHORTTERM FUELTRIM3- -95.3%, LONGTERM FUELTRIM3- 92.1%, LONGTERM FUELTRIM4-97.6%, SHORTTERM FUELTRIM4 - -57.5%, FUEL SYSTEM 1- CLSD1, FUEL SYSTEM 2- CLSD, I WISH I NEW WHAT ALL THIS MEANS, ANY HELP IS APPRECIATED,PLEASE!!

n for two to three minutes. Then it goes off till the next start. Sometimes it will flash on and off. The sensor in front of radiator has been replaced twice. What could the problem be.

My new battery is going down overnight! I can charge it up in the mornings and I can hear some kind of little electric motor running on top rear of engine. What do you think this is?

when in high it has a loud clicking sound and seems one of the front wheels is bucking this only happens when I do a sharp turn. If I am driving in two wheel drive no problem.

there is two plugs on right side of throttle body,where intake hose is connected,one on top is the air control,i think, the other one is two inches under it,1999 silverado 1500,4.8,V8 VORTEC,4X4

Pulled codes c0035 c0040 front abs sensors and code c0201 ebcm failure. Could this be the cause or has anyone had similar problems like this

Do i have to change my fuel pump to fix this?

Cargo light remains on and is causing battery issues. Is there a way to control the cargo light duration?

I would like to know what pid specs to look for when monitoring transmission while doing a driving test.

Jacked the rear end up tires move fine in 1st gear but will want to stop spinning in all other foward gears. Any advise. Thanks

My 2002 Chevrolet Silverado 1500 extended cab V8 1/2 Ton 4WD with Floor Mounted 4wd shifter, will sometimes stick and not disengage from 4wd back to 2wd. Also makes noise.

Driving on the highway, the RPM's shot up and then I noticed the trans guage was higher than normal. Just had a new engine put in it and all fluids changed and checked.

I know what the part looks like & that it has to do with the gas tank. Cannot find where it is - hopefully I do not have to pull gas tank !
Thanks Tom Mc

runs just fine first thing that happened was the remote quit working and tire pressure light came on put air in tires light still on new bat in remote will not work.

is on with code p0785 shift speed solinoide

get a little water in oil loses about a quart between oil changes,and water does not flow through intake so how could this cause it?