911
questions

I start my car then it shakes bad. When I drive it goes too fast or slows down, there has been times when I am driving and the car just simply turns off. My check engine turns off and on my tire light is always on checked them and there is nothing wrong with them, when I change my gear to drive my car won't move at times. It's on going problems with this car .

had bad throttle posistion sensor changed it. Shortly after the fan coolant temp sensor went bad replaced it. Then car overheated due to bad sealant on lower intake end. boughgt gasket kit changed head, exhaust intake upper and lower. changed injector and fuel pressure regulator orings. clean and checked plugs.now car cranks over slow but does not run. have checked for spark,fuel, THEY ARE GOOD TRIED STARTING FLUID NOTHING. IM LOST AND NEED HELP

Ok my problem is my serpentine belt is off a couple notches on the crankshaft it aligned the right way on the alternator and the water pump and the the other pulley and down the tensioner and even on the crankshaft but when I start the car it is been pulled a couple notches off of the crankshaft it hasn't fallen off it's quite a lot and squeals alot and you know it doesn't seem to be running as well as it should and I'm sure that it's going to break soon if I don't get it to stay on the crankshaft is there something I can do is the crankshaft adjustable or is there some other part that I missing

Just purchased a 2002 MC SS with 37K miles. The car has problems starting on the first try but starts right up on the second try. This seems to happen when the car is hot. The crankshaft sensor has just been replaced.

I want a fair price.

Problem just started today car just leaked from under car

has 2 horns, bought new one, didnt work. put back old horns, worked a lil louder, now back to hardly nothing again.

It just stopped blowing but i still feel heat just not from where it suppose to come from.

Check engine light on due to vent control valve

Hello, I just bought a 2002 Monte Carlo SS with about 156,000 miles. It has a few problems like stalling that we are working on. But another issue it has is that the Service Traction System light comes on intermittently. I thought maybe it was because it was set as on and not off but rather it is on or off the warning light still comes on. Any ideas about what to do with this? Thank you in advance for your time.

of the vehicle all down the parking lot. I can't afford to put my car in shop just got back to work but want to know how difficult is it to replace the radiator, my dad does some mechanic work the motor mounts on this vehicle is different from the cars we use to work on, need advice on removing the old radiator