Chevrolet Metro Questions

Answered Chevrolet Metro Questions

Ask a Question
View:RecentAnsweredUnanswered
Uncertain when the high-pitched buzzing sound started, it's my wife's car, but it seems she started to mention the noise some time after we bought new tires. It's difficult to explain the noise; I do have a recording...
Overheat leaked all oil starts it tugs but no force from engine when I step on gas when I turn it on its ok Istep on gas Iit tugs a little but wont move
While driving, the ability to accelerate disappeared. At first I thought it was the engine, but when I pulled over the engine was still running. There was no noise at all when this happened just a loss of accelerati...
When my 98 geo 5speed with 1.0 gets real cold it won't start just cranks over after u push it inside and it warms up it starts fine enyone have an idea
I just wonder if any of these sensors are bad, but i don't have a check engine light on it just they dosen't finish their cycle still flashing in the obd II reader and dtc present. thanks
I was told I my starter is going out even though it's new
NEW ALTINATER AND IT STILL LOOSES POWER I CHECKED FUSES UNDER THE HOOD AND THE FUSE BOX BY THE DOOR.
looks like a bearing race on my torque converter keeps dumping trans fluid on ground.. ive pulled motor 3 times do to this what do i do now?
We had the battery checked and it is good, even bought a new battery and tried that. While the engine was running, we have removed both battery cables and the engine continues to run. If we turn off the engine, it w...
What type of fluid to use, Can you drain the converter, how many quarts of fluid with the converter drained and without, how to properly check the fluid level. Thank you: Modocker
a few days ago I went to start my car to go to work but it would not start the engine is getting electrical power and the starter is doing its job but it does not crank. It has 88K miles.
The main pulley on my metro moved about a quarter inch out and now the belts wont stay on. I tried to move it back into position by loosening the bolt, but it wont budge. The car only had 120k on it and runs great bes...
2000 Chevy Metro LSI 4cyl automatic. While driving, engine slows like it's flooding, the Service Engine Soon light starts flashing, then suddenly surges foward and accelerates normally. May not do it again for days....
just need to know how boot under coil pack comes off ,, if just held by a lip or what
It seems like it always starts when it's cold in the morning. Then we'll drive it for 5-10 miles, then let it sit for 15-20 minutes or more, try to start it and it just cranks. Just turns over and nothing happens. At ...
Recently our Metro would not start.Even after an attempted jump start...no luck. Our mechanic diagnosed a failed starter and recommended replacing and older and weakening battery.Both items were replaced. One week lat...
my car is loosing speed going uphill, and the check engine light is on.
Ok I got a two part question for anyone who can anwser them first i have a 98 metro and when the vehicle is warmed up, I get in to start it and it turns over but will not start I turn it off and continue to try it f...
where is the crank sensor located
I have a 1999 Chevy Metro Lsi with 1.3 liter four cylinder. I have an after-market hood without the stock information, so i do not have the spark plug gaping info which I need. I also would like a recommendation on w...
my car has this sound coming from the brakes,sounds like gravel in it,I take to my macanic,he says theres nothing there,any idea any one?
Code p0300,random misfire.The car has new coil pack,new wires and plugs,new timing belt,all sensors have been replaced except for crank positioning sensor,I have my doubts thats the problem or the code would be differ...
headlights not coming on - highbeam work/running lights work/replaced bulb and fuses. Is this an electical problem, radio works, heat/air conditioner works. Car drives fine.
When i bought the car, my trunk lock was broken. I haven't been able to find one anywhere online. Does anyone know where i can find one at?
Idle started going up and down worst when head lights in on position. Then service engine soon light came on. took car too jiffy lube hooked up to computer came up p0400
I was in a accident that caused my engine to overheat, and stall. I took it to the shop and they informed me that they would need to change the thermostat in order to see if there is any internal damage to the engine...