Chevrolet Impala SS Questions

Answered Chevrolet Impala SS Questions

Ask a Question
View:RecentAnsweredUnanswered
I just bought this 08 impala ss, cause sounded simple fix. Oil high dirty but looks normal. Coolant low. 5.3 can get to barely crank with good jumper even on starter post. Then next time starter just engage and don't ...
PUMP IS NEW AND JUST PUT NEW WIRES IN THE TANK. PUMP WILL ONLY PRIME ONCE IN AWHILE. NOW I AM GETTING A RUNNING RICH CODE
Start then stalling happens at ever attempt and the 2 to 3 sec. run time seem to be equal on every attemp
The problem normally happens if I have to make multiple stops which causes me to start and stop the car frequently. I know the problem is about to happen because when I apply the gas the car hesitates for about 2-3 se...
I have a new engine spark plugs also bought a new opti crank sensor and also have a brand new fuel pump I'm not understanding why when I accelerate on the gas it stall and it will cut off and it takes a while before i...
I bought the car used. Ever since I bought it my traction control light stays on, my ABS light stays on, and the information center of the gage cluster says "service suspension system" the blinker also blinks really f...
My heater is shutting off intermittently as are my directionals (both). The heater seems to shut off when i go over a bump. The directionals seem more random.
Generally my directionals work when I first start the car but then fail at different points during the day. Both directionals fail and I have tried replacing the fuse.
spark plug? I was told I would need to use a 10mm socket in order to get to the spark plug. Any guidance would be appreciate.
I'm currently getting low oil pressure and "check gauge" light when idling. What do i need to check oil pressure. I'm assuming if oil pressure is fine then i need to replace the sending unit. Has anyone had this problem?
This also happened last week and it seems to be fine on the drive home. i checked and the coolant is not low. It also appeared as if the temp gauge was not working. when i got to work the engine was not hat at all. th...
my oil somehow ended up in my coolant. i didnt have symptoms, no overheat or drivability issues. i had just decied to check my coolant and saw chocolate ice cream layer in the reservoir. so i drained the coolant an...
no overheat, no drivability issues either. I just happened to check the coolant and the reservoir was full of chocolate sludge. My engine oil leaked in to my coolant somehow. I have drained the coolant and the cool...
I am install an engine and need to know what is the easiest way from the top are bottom.
If the car has been sitting overnight and I start it the trans will not engage till I run it till running temperature is reached and I turn it off and come back in 15 minutes and then it is fully functional.
I have a 96 SS impala and it won't start I changed the spark plugs and wires, igniton coil, ignitor, cap, rotor, distributor, air flow meter, fuel pump and nothing worked. can anyone point me in the right direction in...
I have a misfire and my traction control light is on . I have the plug I just need to know which one to replace
The car is using more gas and the check engine lit is on code is po522 and po523. Can that cause this problem
speedo jumps,alt gauge droppes off at 70mph
2nd time cost me 300.00 at dealer. Now have 78000 miles, and warning lights come on intermittently, sometimes 2 or 3 times a day. Not sure what to do...notified dealer at last oil change, but could find no EVIDENCE of...
added a fuel additive, changed o2 sensors, cleaned mass air flow sensors, runs really smooth except at start