Close

Chevrolet G Series Van (G20) Questions

Get answers to questions about your Chevrolet G Series Van (G20) at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
301
questions

What can be the problem,I have a new distributor, gasket on throttle body..

Can't figure out where on the transmission it's located. It's actuall an '89 and the part is a bwd s8030, can anyone help???

Have no current to wire to starter solonoid

Shes ran fine until then.

85 G20 series needs tune up and love never been so close to a inverted engine don't even know how to look at it lol

While trying to replace my thermostat, I tried to remove the intake manifold and one of the bolts broke off. Now I must figure out how to remove this bolt without damaging my intake manifold.

I have change the fuse but it still keeps on blowing

I'm changing my radiator well one I took out has a heater hose connected to it and the used radiator I got doesn't have a place for that heater hose is there another place I can route that hose to?

I put 6 but still low and going slow now but reverse fine and fluid drain from coolant line

I put 6 quarts in she drive but I have to gun it in drive but reverse work fine

At start up it revs high like gas pedal is down. Turned off, tried again, same result. Turned off again, checked carb cables if stuck. Tried to start again and now just turns over. Any ideas would be helpful thanks

Timing belt gone vam won't move

it is a 1989 g20 van. the alternator will drop output and run the battery down. the battery is new and filled and when i test the alternator it puts out 14 v. I think i have a short but can't find it.

Van drove fine. Parked it for an hour. Acted like it was out of gas, put gas in (thought maybe gauge had quit), didn't help. Idles erratic, backfires with black smoke when driving. Using way more fuel than before. Runs too rough to drive. Checked for basic vac leaks.

Upon driving it backfires and sometimes stalls. Already changed plugs, spark plug wires, rotary cap, distributor cap, coil pack. Also, add fuel system cleaned and new air cleaner.

There's only fuel going into the seventh and eighth cylinders.

Engine start fine but weak power to gas n move van, no compression .