Chevrolet G Series Van (G20) Questions

All Chevrolet G Series Van (G20) Questions

Ask a Question
my battery is fantastic but at times the starter will not engage, could this be a problem with the steering coloum/ingnition switch or do you think starter is screwed?
I was charging an iceless cooler and the charger to the cooler was hot when I unplugged it after the radio stopped
A mechanic put in a Rebuilt engine. Van runs awhile but won't start after 15-30 minutes. it has to sit 40 minutes before it will start again. has new Alternator, Starter, Water Pump, Radiator, Battery, and full Tune u...
Van starts up and runs fine when cold. Sea light stays on. Once truck is up to speed it runs fine. When I give it gas it has a misfire. Temp needle doesn't move above 100.
it looks like a cover for something fell off and now it's spinning and grinding when I drive it. It's not the alternator I don't know what it is it's not my vehicle I just Need it fixed. please help
i changed the fuel pump i checked the map sensor with bobby pin no change i also checked oil sending unit changed fuel filter and i cleaned the throttle body and injectors. i checked all the fuses i am stumped and won...
5 o v8 it acts like it starving for fuel at take off then it runs great after it picks up speed? New air and fuel filter, has 60 thousand miles.
It has power to switch when off its 12v on shows 4v and to starter, but doesn't engage when cross jumping the sealenoid
This Chevy van has the side-by-side 4 headlight system. I could swear that I'd seen all four lights on when the hi-beams were on before, but noticed recently that switching on the hi-beams turned off the low beams. A ...
wont shift out of first.will manually go in second. and speedometer doesnt work. checked sensor and changed for the spedo pretty much checked everything ,so I thought
I read there may be wires connected to things on the Dashboard and elsewhere on the front seats, as far as I can see there is not much the passenger seat does as compared to the driver's seat and it does not have the ...
I have tightened the battery cables once and it came back on.
Linkage doesn't engage reverse. Drove 600 miles w/ no problems,slipping or noise. Reverse just went out. Need to know how to diagnose or what trans fit this van or how to fix it. Please.. thank you
It will not start back up until it sets for a while I replaced the ignition modulator, rotor and cap
Been having some issues with rear end noise when shifting from P to D and while driving from 1st to 2nd gear. The u joints are good but there is play in the driveline. Has 150,some odd miles. Should I replace the who...
Am having a problem with the brakes on my van. Had new brakes installed about a year ago so they are in good shape. I don't use the the van that much so there is not much mileage on them. Just recently my pedal slowl...