Chevrolet Blazer Questions

Answered Chevrolet Blazer Questions

Ask a Question
View:RecentAnsweredUnanswered
when I come to a stop sign, my brakes will slide. I have several time gone through a stop sign. when I pull the fuse for the abs out of the top of the fuse box. my brakes are fine. however I loose my 4 wheel drive wit...
The blazer is a 4x4, it will turn over, but its getting harder and harder with mutiple cranks till it does.. i had the battery replaced and a basic tune up of wires and plugs , but the problem continues.. once it star...
it's warm to start it again. It seems like it isn't getting gas or not firing properly. Any help would be appreciated !! Thanks
My 03 blazer engine light came on...scanned it bank 1 sensor 1 changed it with new one reset it..next day light came back on...po1035...checked fuse good..what wires and what voltage from the truck sides connector??
Fuel pump does run. Replaced fuel filter. Cleaned MAF sensor. Checked all lines for connection and they are good. Did a passkey II bypass and still nothing. Any advice?
remove and replace R&R,,hub assembly 5134124 moog ,, ball joint k5335
I know where the one that goes to the gauges is located but I have checked everywhere possible and still haven't found it. I tested the one that goes to the gauge by taking it out and the gauge quit then when I put it...
while driving a little blue smoke comes out of the tail pipe and sprays oil on the tailgate .
Engine will crank but will not start until several minutes delay. When gauge lights come on, engine will start. When outside temperature is 60 to 70 degrees the wait time is about 2-5 minutes. When outside temp is 40 ...
Driver side power window needs several pushes of the power window button. Seems to be an electrical issue. Restart engine and window moves up.
I let off gas and it will grab but as soon as I step on gas it will start to slip
Will start of given jumpstart dies immediately Is it the alternater or something else wrong?
1983 K5 full size Blazer, 4X4, GM 10 bolt axle. Drivers side upper ball joint stud, and nut move back and forth 1/8th inch as the hub is lifted, and lowered. Axle is supported and wheel is removed. Can the adjuster...
runs great cold until it warms up then it misfires at idle only... goes away as soon as you drive down the road... smooth idle cold but as soon as it warms up that's when it misfires at idle .... runs good and drives ...
Hard idle, trouble starting, smell gas, service engine soon light is on, hear a hum under the hood while driving
Going up a hill I had gas pushed down for power, service engine light came on, and it felt like less power. Once at a stop it was sputtering like it was going to die. Parked and idling it will go from high to low an...
Digital controller would not illuminate or come on. I replaced it and it does illuminate and go's through all the motions [heat, defrost etc.]
I font have heat but everything works in the dash. blowers work good just no heat.
The diagnostic reading said the oxygen sensor was faulty. I replaced it. I also replaced the air valve sensor.The vehicle still runs the same.